summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-02-13 18:25:50 +0100
committerwillemw122021-02-13 18:25:50 +0100
commita441ba9a7f28ff52750099aaec2602f27475c016 (patch)
tree6b56c35a5c81f59d226ce04a0398c3a1a257ce20
downloadaur-a441ba9a7f28ff52750099aaec2602f27475c016.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd910a21cf63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = media-downloader-git
+ pkgdesc = GUI front-end for downloading media files (youtube-dl, ...)
+ pkgver = 1.0.0.r57.ge3b332a
+ pkgrel = 1
+ url = https://github.com/mhogomchungu/media-downloader
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ depends = qt5-base
+ optdepends = youtube-dl: download files
+ optdepends = wget: download files
+ provides = media-downloader
+ conflicts = media-downloader
+ source = media-downloader-git::git+https://github.com/mhogomchungu/media-downloader.git
+ md5sums = SKIP
+
+pkgname = media-downloader-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2af92204572f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+pkgname=media-downloader-git
+pkgver=1.0.0.r57.ge3b332a
+pkgrel=1
+pkgdesc="GUI front-end for downloading media files (youtube-dl, ...)"
+arch=('x86_64')
+url='https://github.com/mhogomchungu/media-downloader'
+license=('GPL')
+depends=('qt5-base')
+makedepends=('cmake' 'git')
+optdepends=('youtube-dl: download files' 'wget: download files')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=release ..
+ make
+}
+
+package() {
+ cd $pkgname/build
+ make DESTDIR="$pkgdir/" install
+}
+