summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans Ole Hatzel2017-04-18 16:47:02 +0200
committerHans Ole Hatzel2017-04-18 16:47:02 +0200
commitaad960e779dfb28555ae362b428c86fbf0714db5 (patch)
tree65714a16d61a47898798635fa90dbd00040bccb8
parentb654b230e009f7b04c01f2e013977fd06cc2d9da (diff)
downloadaur-aad960e779dfb28555ae362b428c86fbf0714db5.tar.gz
Handle git submodules in prepare.
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3fa8fd8780a0..baa31efd1b85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,14 +12,21 @@ conflicts=('mediaqbot')
makedepends=('git' 'python-setuptools')
provides=('mediaqbot')
url='https://github.com/raffomania/mediaqbot'
-source=("git+https://github.com/raffomania/mediaqbot.git")
-sha256sums=('SKIP')
+source=(
+ "git+https://github.com/raffomania/mediaqbot.git"
+ "git+https://github.com/hatzel/python-mpv.git"
+)
+sha256sums=('SKIP' 'SKIP')
-package() {
- cd "${_gitname}"
- git submodule update --init --recursive
+prepare() {
+ cd "${_gitname}"
+
+ git submodule init
+ git config submodule."client/mediaqclient/mpv".url ${srcdir}/mpv
+}
- cd client
+package() {
+ cd "${_gitname}/client"
# Install
python setup.py install --optimize=1 --root="${pkgdir}"