summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-10-14 14:07:55 -0400
committerGuillaume Horel2017-10-14 14:07:55 -0400
commite22ba8d815fdcda3d5ff3722dcf594cfb52219fc (patch)
treecb39fb92fdf5ff8568c8f9a16a9a98b340e97b9a
parent8d52a06fdb9ac6af694271cfecfe613e9a106a6e (diff)
downloadaur-e22ba8d815fdcda3d5ff3722dcf594cfb52219fc.tar.gz
version bump
switch to cmake build
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD50
2 files changed, 37 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfd87f52ee4e..378294bce58a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,25 @@
pkgbase = mediastreamer-git
- pkgdesc = Mediastreamer2 is a GPL licensed library to make audio and video real-time streaming and processing.
- pkgver = 2.10.0.r880.g7f2055c
+ pkgdesc = A library written in C that allows you to create and run audio and video streams
+ pkgver = 2.16.1.r73.g212ca580
pkgrel = 1
- url = http://www.linphone.org/
+ url = https://github.com/BelledonneCommunications/mediastreamer2
arch = i686
arch = x86_64
license = GPL
- makedepends = git
makedepends = cmake
- makedepends = automoc4
makedepends = intltool
- depends = gsm
- depends = v4l-utils
+ depends = ortp-git
depends = ffmpeg
depends = libxv
- depends = ortp-git
- depends = speex
- optdepends = mediastreamer-plugin-msamr-git: amr plugin
- optdepends = mediastreamer-plugin-msx264-git: x264 plugin
+ depends = libupnp
+ depends = bzrtp-git
+ depends = glew
+ depends = libsrtp
+ depends = mbedtls
+ depends = bctoolbox-git
provides = mediastreamer
conflicts = mediastreamer
- options = !libtool
- source = git://git.linphone.org/mediastreamer2.git
+ source = git+https://github.com/BelledonneCommunications/mediastreamer2.git
sha256sums = SKIP
pkgname = mediastreamer-git
diff --git a/PKGBUILD b/PKGBUILD
index 3a46e307d95a..4b683a43a043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,40 @@
+# $Id$
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: AdriĆ  Arrufat <swiftscythe@gmail.com>
+# Contributor: Mark Lee <mark@markelee.com>
+
pkgname=mediastreamer-git
-_basename="mediastreamer2"
-pkgver=2.10.0.r880.g7f2055c
+_pkgname=mediastreamer2
+pkgver=2.16.1.r73.g212ca580
pkgrel=1
-pkgdesc="Mediastreamer2 is a GPL licensed library to make audio and video real-time streaming and processing."
+pkgdesc="A library written in C that allows you to create and run audio and video streams"
arch=('i686' 'x86_64')
-url="http://www.linphone.org/"
+url="https://github.com/BelledonneCommunications/mediastreamer2"
license=('GPL')
-options=(!libtool)
-depends=('gsm' 'v4l-utils' 'ffmpeg' 'libxv' 'ortp-git' 'speex')
-makedepends=('git' 'cmake' 'automoc4' 'intltool')
-optdepends=('mediastreamer-plugin-msamr-git: amr plugin' 'mediastreamer-plugin-msx264-git: x264 plugin')
-source=("git://git.linphone.org/$_basename.git")
+conflicts=('mediastreamer')
+provides=('mediastreamer')
+depends=('ortp-git' 'ffmpeg' 'libxv' 'libupnp' 'bzrtp-git' 'glew' 'libsrtp' 'mbedtls' 'bctoolbox-git')
+# xxd from Vim is needed to build
+makedepends=('cmake' 'intltool')
+source=("git+https://github.com/BelledonneCommunications/mediastreamer2.git")
sha256sums=('SKIP')
-provides=("mediastreamer")
-conflicts=("mediastreamer")
-
-prepare() {
- cd "$_basename"
- ./autogen.sh
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}
build() {
- cd "$_basename"
- ./configure --prefix=/usr --enable-external-ortp --libexecdir=/usr/lib/mediastreamer/
+ cd ${_pkgname}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR="/usr/lib" \
+ -DENABLE_STATIC="NO" .
make
}
package() {
- cd "$_basename"
- make DESTDIR=$pkgdir install
-}
-
-pkgver() {
- cd "$_basename"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
}