summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2017-01-02 22:57:56 +0100
committerSteffen Weber2017-01-02 22:57:56 +0100
commitcb0773dfbdc86c752de99d720d7a25db689d1d46 (patch)
tree3c5a51b97ce22474509a005a10dabece5ea3e9fb
parent2fe684227a3093862d4d35c57858a900fa91e892 (diff)
downloadaur-cb0773dfbdc86c752de99d720d7a25db689d1d46.tar.gz
Update to 13.0.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd8dbbccf45b..41b4b6342bb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Sat Aug 27 20:00:58 UTC 2016
+# Mon Jan 2 21:57:35 UTC 2017
pkgbase = mediathek
pkgdesc = Offers access to the Mediathek of different german tv stations (ARD, ZDF, Arte, etc.)
- pkgver = 12
- pkgrel = 3
- url = http://zdfmediathk.sourceforge.net
+ pkgver = 13.0.0
+ pkgrel = 1
+ url = https://mediathekview.de
arch = any
license = custom
depends = java-openjfx
@@ -13,10 +13,10 @@ pkgbase = mediathek
optdepends = vlc: play files directly from mediathek
options = !strip
options = !zipman
- source = http://downloads.sourceforge.net/zdfmediathk/MediathekView_12.zip
+ source = https://download.mediathekview.de/stabil/MediathekView-13.0.0.tar.gz
source = mediathek
source = mediathek.desktop
- md5sums = e754dd7a1e6f77ed898288c2f270eaa4
+ md5sums = f9ab144b5f4cf7aaaab5db6b28036c97
md5sums = 461b97eecd40ec40e46b66eb219c92b9
md5sums = bad6e1fdc948ac0e41b8535509cf944d
diff --git a/PKGBUILD b/PKGBUILD
index e1159b5864f7..9f7c20cbcf78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,34 @@
# Contributor: Benedikt 'linopolus' Mueller <benemue at googlemail dot com>
pkgname=mediathek
-pkgver=12
-pkgrel=3
+_realname=MediathekView
+pkgver=13.0.0
+pkgrel=1
pkgdesc="Offers access to the Mediathek of different german tv stations (ARD, ZDF, Arte, etc.)"
arch=(any)
-url="http://zdfmediathk.sourceforge.net"
+url="https://mediathekview.de"
license=('custom')
depends=('java-openjfx')
optdepends=('mplayer: record streams'
'flvstreamer: stream flash'
'vlc: play files directly from mediathek')
options=(!strip !zipman)
-source=(http://downloads.sourceforge.net/zdfmediathk/MediathekView_${pkgver}.zip
+source=(https://download.mediathekview.de/stabil/$_realname-$pkgver.tar.gz
$pkgname
$pkgname.desktop)
-md5sums=('e754dd7a1e6f77ed898288c2f270eaa4'
+md5sums=('f9ab144b5f4cf7aaaab5db6b28036c97'
'461b97eecd40ec40e46b66eb219c92b9'
'bad6e1fdc948ac0e41b8535509cf944d')
package() {
+ cd $_realname-$pkgver
install -d $pkgdir/{opt/$pkgname/{lib,bin},usr/{bin,share/{{doc,licenses}/$pkgname,applications,pixmaps}}}
- install -m755 $pkgname $pkgdir/usr/bin/
- install -m644 MediathekView.jar $pkgdir/opt/$pkgname/
+ install -m755 ../$pkgname $pkgdir/usr/bin/
+ install -m644 $_realname.jar $pkgdir/opt/$pkgname/
install -m644 -t $pkgdir/opt/$pkgname/lib lib/*
install -m755 bin/flv.sh $pkgdir/opt/$pkgname/bin/
- install -m644 $pkgname.desktop $pkgdir/usr/share/applications/
- install -m644 Info/MediathekView.png $pkgdir/usr/share/pixmaps/
+ install -m644 ../$pkgname.desktop $pkgdir/usr/share/applications/
+ install -m644 Info/$_realname.png $pkgdir/usr/share/pixmaps/
install -m644 Anleitung/Kurzanleitung.pdf $pkgdir/usr/share/doc/$pkgname/
- install -m644 -t $pkgdir/usr/share/licenses/$pkgname Copyright/*.*
+ cp -R Copyright/* $pkgdir/usr/share/licenses/$pkgname
}