summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEinhard Leichtfuß2021-12-25 02:49:48 +0100
committerEinhard Leichtfuß2021-12-25 02:49:48 +0100
commit7a0eb76dd5bb99c9e2751d87702bdc1987beb6b9 (patch)
tree51b22e8867a4bfd723575b145bcee84e3e4c1500
parent62dfa048d3872c7cd5d35994a8ff57b99ba4774e (diff)
downloadaur-7a0eb76dd5bb99c9e2751d87702bdc1987beb6b9.tar.gz
Fix install()
Only specific dotfiles excluded now; no `cp -a'.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b41d8006579..e6d17ade908f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mediawiki-extension-lockdown-git
pkgdesc = MediaWiki extension implementing per-namespace group permissions
pkgver = r180.5d8ea76
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://www.mediawiki.org/wiki/Extension:Lockdown
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index c39076a0b768..643f550ab00e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ _branch="REL${_mediawiki_mainver/./_}"
pkgname="${_pkgname_base}-git"
epoch=1
pkgver=r180.5d8ea76
-pkgrel=2
+pkgrel=3
pkgdesc="MediaWiki extension implementing per-namespace group permissions"
arch=('any')
url="https://www.mediawiki.org/wiki/Extension:${_extname}"
@@ -35,5 +35,8 @@ package()
local ext_dir="/usr/share/webapps/mediawiki/extensions/${_extname}"
install -d -m755 "${pkgdir}${ext_dir}"
- cp -a "$_extname"/* "${pkgdir}${ext_dir}/"
+ cd "${_extname}"
+ find . -mindepth 1 -maxdepth 1 -regextype posix-extended \
+ \! -regex './\.git(|ignore|review)' \
+ -exec cp -RP '{}' "${pkgdir}${ext_dir}/" \;
}