summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwh2019062023-11-24 00:34:30 +0800
committerwh2019062023-11-24 00:34:30 +0800
commita8321ae3d36810da384ba4b9b9effb801bb99d44 (patch)
treed688a627c9562c655e311b6857803cb3709dd527
parent3ccdbe2f2a12303816eae0ddc4107b2564bc0472 (diff)
downloadaur-a8321ae3d36810da384ba4b9b9effb801bb99d44.tar.gz
Use metadata in the git repo
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD55
3 files changed, 12 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0baa62e69289..c08c37bcc9d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = medifier-git
- pkgdesc = I just don't know why the Edifier Connect takes up more than 200MB on my phone.
- pkgver = 0.1.r7.g1e4fa5a
+ pkgdesc = An open-source alternative to the Edifier Connect app
+ pkgver = 0.2.r5.g91c3edd
pkgrel = 1
url = https://github.com/wh201906/mEDIFIER
arch = any
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index b7004b888c7b..447e60cb71df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,17 @@
_pkgname=mEDIFIER
pkgname=medifier-git
-pkgver=0.1.r7.g1e4fa5a
+pkgver=0.2.r5.g91c3edd
pkgrel=1
-pkgdesc="I just don't know why the Edifier Connect takes up more than 200MB on my phone."
+pkgdesc="An open-source alternative to the Edifier Connect app"
arch=('any')
url="https://github.com/wh201906/mEDIFIER"
license=('MIT')
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
replaces=()
-depends=(qt5-serialport
- qt5-connectivity)
-makedepends=(qt5-tools
- git)
+depends=('qt5-serialport' 'qt5-connectivity')
+makedepends=('qt5-tools' 'git')
backup=()
options=('!strip')
install=
@@ -24,55 +22,20 @@ sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}/"
- git describe --long --tags | sed 's/v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/V//g;s/v//g;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${srcdir}/${_pkgname}/Qt/"
qmake
- make
+ make -j$((`nproc` + 1))
}
package() {
install -Dm0755 "${srcdir}/${_pkgname}/Qt/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-git}"
-
- install -Dm0644 /dev/stdin "${pkgdir}/usr/share/metainfo/io.github.wh201906.medifier.metainfo.xml" << EOF
-<?xml version="1.0" encoding="UTF-8"?>
-<component type="desktop-application">
- <id>io.github.skiars.medifier</id>
-
- <name>medifier</name>
- <summary>medifier</summary>
-
- <metadata_license>CC-BY-SA-4.0</metadata_license>
- <project_license>MIT</project_license>
-
- <description>
- <p>
- I just don't know why the Edifier Connect takes up more than 200MB on my phone.
- </p>
- </description>
-
- <launchable type="desktop-id">io.github.skiars.medifier.desktop</launchable>
-</component>
-
-EOF
-
- install -Dm0644 /dev/stdin "${pkgdir}/usr/share/applications/io.github.wh201906.medifier.desktop" <<EOF
-[Desktop Entry]
-Name=SerialTool
-Name[en_US]=mEDIFIER
-Name[zh_CN]=mEDIFIER
-Exec=medifier
-Terminal=false
-Type=Application
-Icon=medifier.png
-Comment=I just don't know why the Edifier Connect takes up more than 200MB on my phone.
-Comment[zh_CN]=
-Categories=Development;Debugger;
-EOF
-
+ install -Dm0644 "${srcdir}/${_pkgname}/deploy/aur/io.github.wh201906.medifier.qt.metainfo.xml" "${pkgdir}/usr/share/metainfo/io.github.wh201906.medifier.qt.metainfo.xml"
+ install -Dm0644 "${srcdir}/${_pkgname}/deploy/aur/io.github.wh201906.medifier.qt.desktop" "${pkgdir}/usr/share/applications/io.github.wh201906.medifier.qt.desktop"
install -Dm0644 ${srcdir}/${_pkgname}/LICENSE* -t "${pkgdir}/usr/share/licenses/${pkgname}/"
-# install -Dm644 "$srcdir/${_pkgname}/src/icon/icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+# install -Dm644 "$srcdir/${_pkgname}/src/icon/icon.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
# install -Dm644 "${srcdir}/${_pkgname}-${pkgver}/${_pkgname}/pkg/20-usb-serial.rules" "${pkgdir}/etc/udev/rules.d/20-usb-serial.rules"
}