summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsyui2017-03-30 00:16:32 +0900
committersyui2017-03-30 00:16:32 +0900
commit58d2742abb5c89e99f1e171d47cfc4226e5ab4f1 (patch)
tree6715c9b7382bafe6d2a412805e06a80d6a891781
downloadaur-58d2742abb5c89e99f1e171d47cfc4226e5ab4f1.tar.gz
first
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD31
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..639ef5ec0f98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# 水 3月 29 15:16:08 UTC 2017
+pkgbase = medigo
+ pkgdesc = medium cli client, api, medigo, golang, oauth
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/syui/medigo
+ arch = x86_64
+ arch = i686
+ license = MIT
+ noextract = https://github.com/syui/medigo/releases/download/0.1/linux_amd64_medigo
+ noextract = https://github.com/syui/medigo/releases/download/0.1/linux_386_medigo
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/syui/medigo/releases/download/0.1/linux_amd64_medigo
+ source = https://github.com/syui/medigo/releases/download/0.1/linux_386_medigo
+ sha1sums = df39df00f1aed7211c2410889b60242176b12332
+ sha1sums = c48fb5dc4907e59050838d7a1c216caefd1f20c2
+
+pkgname = medigo
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5f6bb1b1102a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+linux_amd64_*
+linux_386_*
+medigo
+pkg
+src
+bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffd8d3b3c8cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: syui <syui@users.noreply.github.com>
+pkgname=medigo
+pkgver=0.1
+pkgrel=1
+pkgdesc="medium cli client, api, medigo, golang, oauth"
+arch=('x86_64' 'i686')
+url="https://github.com/syui/medigo"
+options=('!strip' '!emptydirs')
+license=('MIT')
+source=("$url/releases/download/$pkgver/linux_amd64_$pkgname"
+ "$url/releases/download/$pkgver/linux_386_$pkgname")
+noextract=(${source[@]%%::*})
+sha1sums=('df39df00f1aed7211c2410889b60242176b12332'
+'c48fb5dc4907e59050838d7a1c216caefd1f20c2')
+
+package() {
+ mkdir -p ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ if [ "`uname -m`" = "x86_64" ];then
+ mv ../linux_amd64_$pkgname $pkgname
+ chmod +x $pkgname
+ fi
+ if [ "`uname -m`" = "i684" ];then
+ mv ../linux_386_$pkgname $pkgname
+ chmod +x $pkgname
+ fi
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ sudo install -Dm755 "$pkgdir/usr/bin/$pkgname" /usr/bin
+}
+
+# vim:set ts=2 sw=2 et: