summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladislav Botvin2017-08-17 23:57:10 +0300
committerVladislav Botvin2017-08-18 00:05:19 +0300
commit475527ed2691df777aa00ea0a48f8b6d1490d087 (patch)
treea50e8d110646f36bc493d971261247d565107d98
downloadaur-475527ed2691df777aa00ea0a48f8b6d1490d087.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD41
-rw-r--r--medis3
-rw-r--r--medis.desktop9
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e5571448509
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = medis
+ pkgdesc = Medis is a beautiful, easy-to-use database management application for Redis.
+ pkgver = 0.6.1.39
+ pkgrel = 1
+ url = https://github.com/luin/medis
+ arch = any
+ license = MIT
+ makedepends = npm
+ makedepends = asar
+ makedepends = git
+ depends = electron
+ source = medis-git::git+https://github.com/luin/medis.git
+ source = medis.desktop
+ source = medis
+ md5sums = SKIP
+ md5sums = F9B462B94D50FB4086D94FD420558B34
+ md5sums = 05074FDFE9D1FAA78550ED6551CF447B
+
+pkgname = medis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b026ebbe206e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: darkvlados@gmail.com
+
+pkgname=medis
+pkgver=0.6.1.39
+pkgrel=1
+pkgdesc="Medis is a beautiful, easy-to-use database management application for Redis."
+arch=("any")
+url="https://github.com/luin/medis"
+license=("MIT")
+depends=('electron')
+makedepends=('npm' 'asar' 'git')
+source=("${pkgname}-git::git+https://github.com/luin/medis.git"
+ 'medis.desktop'
+ 'medis')
+md5sums=('SKIP'
+ 'F9B462B94D50FB4086D94FD420558B34'
+ '05074FDFE9D1FAA78550ED6551CF447B')
+
+pkgver() {
+ cd "${pkgname}-git"
+ git describe --tags | sed 's/\(.*\)-.*/\1/' | tr - .
+}
+
+prepare() {
+ cd "${pkgname}-git"
+ git reset --hard bb76f74112870d46cc6b6e033ab21ea4737a46d9
+}
+
+build() {
+ cd "${pkgname}-git"
+ npm install
+ npm run build
+ asar p . ../medis.asar
+}
+
+package() {
+ install -Dm0755 -t "${pkgdir}/usr/bin" medis
+ install -Dm0644 -t "${pkgdir}/usr/share/applications" medis.desktop
+ install -Dm0644 -t "${pkgdir}/usr/lib/medis" medis.asar
+ install -Dm0644 "${pkgname}-git/icns/Icon1024.png" "${pkgdir}/usr/share/pixmaps/medis.png"
+}
diff --git a/medis b/medis
new file mode 100644
index 000000000000..04fce60d68a7
--- /dev/null
+++ b/medis
@@ -0,0 +1,3 @@
+#!/usr/bin/sh
+
+exec electron /usr/lib/medis/medis.asar "$@"
diff --git a/medis.desktop b/medis.desktop
new file mode 100644
index 000000000000..fadc3bf0ae31
--- /dev/null
+++ b/medis.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Name=Medis
+Comment=Management application for Redis
+Icon=medis
+Exec=medis %U
+Categories=Development;
+StartupNotify=false
+Terminal=false