aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoror2019-01-05 04:55:10 +0200
committeror2019-01-05 05:04:06 +0200
commitd286863c081ec6313e0c25a6a3812bdac13bd176 (patch)
treee95b967ef339c15129dd80caa4f68cb31f0daad4
downloadaur-d286863c081ec6313e0c25a6a3812bdac13bd176.tar.gz
The first version
It has some issues, not serious, you can read about it on the forum: https://bbs.archlinux.org/viewtopic.php?pid=1824343#p1824343 In short word: * Some warnings about ELF file, I was told that it is OK * unknown license because the developers doesn't have one yet. ``` medivia E: ELF files outside of a valid path ('opt/'). medivia W: ELF file ('opt/medivia/medivia') lacks FULL RELRO, check LDFLAGS. medivia W: ELF file ('opt/medivia/medivia') lacks PIE. medivia E: unknown is not a common license (it's not in /usr/share/licenses/common/) ```
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
-rw-r--r--README.md16
-rw-r--r--medivia.desktop10
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28d730d01cf8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = medivia
+ pkgdesc = Client for medivia.online game server. This is mmorpg game based on Tibia.
+ pkgver = 2.4.0
+ pkgrel = 2
+ url = https://medivia.online
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = chrpath
+ noextract = medivia-2.4.0.tar.gz
+ source = medivia-2.4.0.tar.gz::https://medivia.online/uploads/downloads/medivia-2.4.0-linux-32bits.tar.gz
+ source = medivia.desktop
+ md5sums = 70a59bd2857a14256a6a20b3d00c0abd
+ md5sums = 5808058b5bdea0b87199b34fe1dc1319
+ depends_i686 = libglvnd
+ depends_x86_64 = lib32-libglvnd
+
+pkgname = medivia
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..48d23192e391
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*.tar.xz
+/*.tar.gz
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b1c895e9af7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Igor Deyashkin <igor_deyawka@mail.ru>
+pkgname="medivia"
+pkgver="2.4.0"
+pkgrel=2
+pkgdesc="Client for medivia.online game server. This is mmorpg game based on Tibia."
+arch=('i686' 'x86_64')
+url="https://medivia.online"
+# I am not sure what license is used
+license=('unknown')
+depends_x86_64=('lib32-libglvnd')
+depends_i686=('libglvnd')
+makedepends=('chrpath')
+source=("$pkgname-$pkgver.tar.gz::https://medivia.online/uploads/downloads/medivia-$pkgver-linux-32bits.tar.gz"
+ "$pkgname.desktop")
+
+# The archive does not containing root folder in it. I unextract it later on build stage into separate subfolder.
+noextract=("$pkgname-$pkgver.tar.gz")
+
+# autofill using updpkgsums
+md5sums=('70a59bd2857a14256a6a20b3d00c0abd'
+ '5808058b5bdea0b87199b34fe1dc1319')
+
+prepare() {
+ mkdir -p "$pkgname-$pkgver"
+ bsdtar -xzf "$pkgname-$pkgver.tar.gz" -C "$pkgname-$pkgver"
+
+ chrpath -d "$pkgname-$pkgver/medivia"
+}
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ mkdir -p "$pkgdir/usr/bin"
+
+ cp -Rv "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/$pkgname"
+
+ install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # I am not sure this is a good way
+ ln -s "/opt/$pkgname/medivia" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..31925b6d7c02
--- /dev/null
+++ b/README.md
@@ -0,0 +1,16 @@
+There is the commands I used to create and check the package:
+
+```
+updpkgsums
+gendesk PKGBUILD
+namcap PKGBUILD
+makepkg -f
+pacman -Qip medivia-2.4.0-1-x86_64.pkg.tar.xz
+pacman -Qlp medivia-2.4.0-1-x86_64.pkg.tar.xz
+namcap medivia-2.4.0-1-x86_64.pkg.tar.xz
+makepkg --printsrcinfo > .SRCINFO
+```
+
+`namcap` shows some errors and warnings thougt, but I can't figure out what I can ignore and what I shound fix.
+
+This is my first package, so any criticism and suggestions is appreciated.
diff --git a/medivia.desktop b/medivia.desktop
new file mode 100644
index 000000000000..4d3d0d35c12d
--- /dev/null
+++ b/medivia.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.1
+Type=Application
+Name=Medivia
+GenericName=Online game client
+Comment=Client for medivia.online game server. This is mmorpg game based on Tibia.
+Exec=medivia
+Terminal=false
+StartupNotify=false
+Categories=Application;Game;