summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-07-09 19:34:07 +0200
committerhaawda2019-07-09 19:34:07 +0200
commit2cdf1de4d343e77241c83107b7cae84003299315 (patch)
tree3c3507f4487717b8847b57caf2e195a1c6bac772
parentbd4d741f58ae8271e6ba0b79679df60ab6ef5719 (diff)
downloadaur-2cdf1de4d343e77241c83107b7cae84003299315.tar.gz
Update
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcb0b5b31a51..b4983d648c13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,28 @@
pkgbase = meep
pkgdesc = A free finite-difference time-domain simulation software package
- pkgver = 1.9.0
+ pkgver = 1.10.0
pkgrel = 1
url = http://ab-initio.mit.edu/wiki/index.php/Meep
arch = x86_64
license = GPL
makedepends = gcc-fortran
makedepends = suitesparse
- makedepends = python
makedepends = swig
depends = openmpi
depends = harminv
- depends = libctl>=4.1.0
+ depends = libctl
depends = hdf5
depends = gsl
depends = fftw
depends = guile
depends = julia
+ depends = mpb
optdepends = h5utils: for visualization and conversion of scientific data
options = !libtool
options = !makeflags
- source = meep-1.9.0.tar.gz::https://github.com/stevengj/meep/archive/v1.9.0.tar.gz
- sha256sums = 4754f8b95af8de68145c274ae5baf54f22a49515504b9e197ed0bfdc37aaa2f7
+ options = staticlibs
+ source = meep-1.10.0.tar.gz::https://github.com/stevengj/meep/archive/v1.10.0.tar.gz
+ sha256sums = 3c2eef3e37509ecbd1b5734f8fa93b589bd7089c61b0b1c0296e94ace51e2613
pkgname = meep
diff --git a/PKGBUILD b/PKGBUILD
index a7f304e71087..e599f7c367f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=meep
-pkgver=1.9.0
+pkgver=1.10.0
pkgrel=1
pkgdesc="A free finite-difference time-domain simulation software package"
arch=('x86_64')
url="http://ab-initio.mit.edu/wiki/index.php/Meep"
license=('GPL')
-depends=('openmpi' 'harminv' 'libctl>=4.1.0' 'hdf5' 'gsl' 'fftw' 'guile' 'julia')
-makedepends=('gcc-fortran' 'suitesparse' 'python' 'swig')
+depends=('openmpi' 'harminv' 'libctl' 'hdf5' 'gsl' 'fftw' 'guile' 'julia' 'mpb')
+makedepends=('gcc-fortran' 'suitesparse' 'swig')
optdepends=('h5utils: for visualization and conversion of scientific data')
-options=('!libtool' '!makeflags')
+options=('!libtool' '!makeflags' 'staticlibs')
source=("$pkgname-$pkgver.tar.gz::https://github.com/stevengj/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('4754f8b95af8de68145c274ae5baf54f22a49515504b9e197ed0bfdc37aaa2f7')
+sha256sums=('3c2eef3e37509ecbd1b5734f8fa93b589bd7089c61b0b1c0296e94ace51e2613')
build() {
cd $pkgname-$pkgver
- ./autogen.sh CFLAGS=" -fPIC" --prefix=/usr --enable-shared --with-mpi
- make
+ ./autogen.sh CFLAGS=" -fPIC" --prefix=/usr --enable-shared --with-mpi --without-python
+ make
}
package() {
cd $pkgname-$pkgver