summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2015-06-09 00:36:41 +0200
committerStefan Husmann2015-06-09 00:36:41 +0200
commiteca218057b2c028b5b034ae8432af8b79a2bfebf (patch)
tree77a3055abe7033b2494fcb6747906fd95e8692d7
downloadaur-eca218057b2c028b5b034ae8432af8b79a2bfebf.tar.gz
initial version
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD26
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27559322f6cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = meep
+ pkgdesc = A free finite-difference time-domain simulation software package
+ pkgver = 1.3
+ pkgrel = 1
+ url = http://ab-initio.mit.edu/wiki/index.php/Meep
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-fortran
+ makedepends = suitesparse
+ depends = openmpi
+ depends = harminv
+ depends = libctl
+ depends = hdf5
+ depends = gsl
+ depends = fftw
+ depends = guile1.8
+ optdepends = h5utils: for visualization and conversion of scientific data
+ options = !libtool
+ options = !makeflags
+ source = http://ab-initio.mit.edu/meep/meep-1.3.tar.gz
+ md5sums = 18a5b9e18008627a0411087e0bb60db5
+
+pkgname = meep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e78b0f707edf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Anton Bazhenov <anton.bazhenov at gmail>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=meep
+pkgver=1.3
+pkgrel=1
+pkgdesc="A free finite-difference time-domain simulation software package"
+arch=('i686' 'x86_64')
+url="http://ab-initio.mit.edu/wiki/index.php/Meep"
+license=('GPL')
+depends=('openmpi' 'harminv' 'libctl' 'hdf5' 'gsl' 'fftw' 'guile1.8')
+makedepends=('gcc-fortran' 'suitesparse')
+optdepends=('h5utils: for visualization and conversion of scientific data')
+options=('!libtool' '!makeflags')
+source=(http://ab-initio.mit.edu/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('18a5b9e18008627a0411087e0bb60db5')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure CC=gcc CXX=g++ --prefix=/usr --enable-shared --with-mpi
+ make
+}
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}