summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Lane2020-12-30 14:13:52 +0000
committerChris Lane2020-12-30 14:13:52 +0000
commit07287514473c8bc6b3b02103ee3814e1d85b719e (patch)
tree883a43c340d542ec64c3160375240325db64dfb3
parentc711c6d2662f8f286fc09321674c9bce5cc6cb24 (diff)
downloadaur-07287514473c8bc6b3b02103ee3814e1d85b719e.tar.gz
Fix completions location and add missing license
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 660c6def2a78..b55de224838a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = megacmd
pkgdesc = MEGA Command Line Interactive and Scriptable Application
pkgver = 1.4.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/meganz/MEGAcmd
arch = any
license = custom
diff --git a/PKGBUILD b/PKGBUILD
index 3894cf64ccee..4b3fe07e25f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=megacmd
pkgver=1.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="MEGA Command Line Interactive and Scriptable Application"
url="https://github.com/meganz/MEGAcmd"
arch=('any')
@@ -37,5 +37,13 @@ build() {
package() {
cd "MEGAcmd-${pkgver}_Linux"
- make DESTDIR="$pkgdir" install
+ make DESTDIR=${pkgdir} install
+
+ # change completions location
+ rm -rf ${pkgdir}/usr/etc/
+ install -Dm644 src/client/megacmd_completion.sh ${pkgdir}/usr/share/bash-completion/completions/${pkgname}
+
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
}
+
+# vim:set ts=2 sw=2 et: