summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Lane2021-05-27 10:09:24 +0100
committerChris Lane2021-05-27 10:09:24 +0100
commit69ab0d14e68e80640926325d679b36a33a8496e7 (patch)
treefb57162cb5d91cc0b7a2584153d979666d2a5ce6
parent07287514473c8bc6b3b02103ee3814e1d85b719e (diff)
downloadaur-69ab0d14e68e80640926325d679b36a33a8496e7.tar.gz
Disable ffmpeg in build until megacmd fixes compile
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b55de224838a..ada59a2822b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = megacmd
pkgdesc = MEGA Command Line Interactive and Scriptable Application
pkgver = 1.4.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/meganz/MEGAcmd
arch = any
license = custom
@@ -18,7 +18,6 @@ pkgbase = megacmd
depends = readline
depends = libmediainfo
depends = pcre
- depends = ffmpeg
depends = libuv
source = megacmd-1.4.0.tar.gz::https://github.com/meganz/MEGAcmd/archive/1.4.0_Linux.tar.gz
source = mega-sdk-2337aca38daaca6deedd04d8ea400293503f00ff.tar.gz::https://github.com/meganz/sdk/archive/2337aca38daaca6deedd04d8ea400293503f00ff.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 4b3fe07e25f9..fc59e8b743d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=megacmd
pkgver=1.4.0
-pkgrel=3
+pkgrel=4
pkgdesc="MEGA Command Line Interactive and Scriptable Application"
url="https://github.com/meganz/MEGAcmd"
arch=('any')
license=('custom')
depends=('crypto++' 'zlib' 'sqlite' 'openssl' 'curl' 'c-ares' 'freeimage' 'libsodium'
- 'readline' 'libmediainfo' 'pcre' 'ffmpeg' 'libuv')
+ 'readline' 'libmediainfo' 'pcre' 'libuv')
makedepends=('git' 'autoconf')
_sdkhash="2337aca38daaca6deedd04d8ea400293503f00ff"
source=(
@@ -30,7 +30,9 @@ build() {
cd "MEGAcmd-${pkgver}_Linux"
./autogen.sh
- ./configure --prefix=/usr
+ ./configure \
+ --prefix=/usr \
+ --without-ffmpeg # disabled until #523 is fixed (-ffmpeg dep)
make
}