summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephanie Wilde-Hobbs2020-07-20 01:12:14 +0100
committerStephanie Wilde-Hobbs2020-07-20 01:22:20 +0100
commit80f0ce8c824347c271991573f5f74f4832701160 (patch)
treeda9fad1f2c3d531ea3c093b77e86fa434d16056f
parentce41683a70ca9d79bcf9d5cf9bf91d6a8321e7cc (diff)
downloadaur-80f0ce8c824347c271991573f5f74f4832701160.tar.gz
megacmd 1.3.0-1
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD61
-rw-r--r--megacmd.install11
4 files changed, 55 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 637502c3a50b..742661399b5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,29 @@
pkgbase = megacmd
- pkgdesc = A command-line client for mega.co.nz storage service
- pkgver = 0.012
+ pkgdesc = MEGA Command Line Interactive and Scriptable Application
+ pkgver = 1.3.0
pkgrel = 1
- url = https://github.com/t3rm1n4l/megacmd/
- install = megacmd.install
- arch = x86_64
- arch = i686
- license = MIT
- makedepends = go
- options = !strip
- options = !emptydirs
+ url = https://github.com/meganz/MEGAcmd
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = autoconf
+ depends = crypto++
+ depends = zlib
+ depends = sqlite
+ depends = openssl
+ depends = curl
+ depends = c-ares
+ depends = freeimage
+ depends = libsodium
+ depends = readline
+ depends = libmediainfo
+ depends = pcre
+ depends = ffmpeg
+ depends = libuv
+ source = megacmd.tar.gz::https://github.com/meganz/MEGAcmd/archive/1.3.0_Linux.tar.gz
+ source = mega-sdk.tar.gz::https://github.com/meganz/sdk/archive/b2948c7c77862e99dee912f4fe321d3c6dac6b09.tar.gz
+ sha512sums = 2fd3a3e76d3466d7b20c97a868f9af9d1189fa220e1f632bf37bd131a61f4db16f52fd8c7ff73875af98429d8e26106a16955350a8e92aeecd25c6d6c95de54c
+ sha512sums = 4033188310d7a987eba6b42869c32bdc189eb0e5ad1c71c504dc5e33936066fc2d1fd9308e029ca271a2946e05be284b05a5ce19440cc42d2faba64a65db189b
pkgname = megacmd
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b39f3b2a183f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.gitignore
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index fe1fdf4a818b..018a1e7f887c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,38 @@
-# Contributor : chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
-
+# Maintainer: Stephanie Wilde-Hobbs <hi@stephanie.is>
pkgname=megacmd
-pkgver=0.012
+pkgver=1.3.0
pkgrel=1
-pkgdesc="A command-line client for mega.co.nz storage service"
-arch=('x86_64' 'i686')
-url="https://github.com/t3rm1n4l/$pkgname/"
-license=('MIT')
-makedepends=('go')
-options=('!strip' '!emptydirs')
-source=()
-install="$pkgname.install"
-sha256sums=()
-_gitroot="git://github.com/t3rm1n4l/megacmd.git"
-_gitname=megacmd
-_gitrev=e4c1c963c7d96d55190a74a12d25de05f5aa3033
-
+pkgdesc="MEGA Command Line Interactive and Scriptable Application"
+url="https://github.com/meganz/MEGAcmd"
+arch=('any')
+license=('custom')
+depends=('crypto++' 'zlib' 'sqlite' 'openssl' 'curl' 'c-ares' 'freeimage' 'libsodium'
+ 'readline' 'libmediainfo' 'pcre' 'ffmpeg' 'libuv')
+makedepends=('git' 'autoconf')
+_sdkhash="b2948c7c77862e99dee912f4fe321d3c6dac6b09"
+source=("$pkgname.tar.gz::https://github.com/meganz/MEGAcmd/archive/${pkgver}_Linux.tar.gz"
+ "mega-sdk.tar.gz::https://github.com/meganz/sdk/archive/${_sdkhash}.tar.gz")
+sha512sums=('2fd3a3e76d3466d7b20c97a868f9af9d1189fa220e1f632bf37bd131a61f4db16f52fd8c7ff73875af98429d8e26106a16955350a8e92aeecd25c6d6c95de54c'
+ '4033188310d7a987eba6b42869c32bdc189eb0e5ad1c71c504dc5e33936066fc2d1fd9308e029ca271a2946e05be284b05a5ce19440cc42d2faba64a65db189b')
+
+prepare() {
+ cd "MEGAcmd-${pkgver}_Linux"
+
+ rm -r sdk
+ ln -sf "../sdk-${_sdkhash}" sdk
+}
build() {
- cd "$srcdir"
- mkdir -p "$srcdir/go"
- export GOPATH="$srcdir/go"
- msg "Connecting to GIT server...."
+ cd "MEGAcmd-${pkgver}_Linux"
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
- cd "$srcdir/$_gitname"
- git reset --hard "$_gitrev"
+ sh autogen.sh
+ ./configure --prefix=/usr
make
}
package() {
- cd "$srcdir/$_gitname"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
-}
+ cd "MEGAcmd-${pkgver}_Linux"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/megacmd.install b/megacmd.install
deleted file mode 100644
index b8beadb79c1c..000000000000
--- a/megacmd.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- echo "Create a ~/.megacmd.json file, like this:"
- echo "{"
- echo ' "User" : "youremail@email.com",'
- echo ' "Password" : "yourpassword",'
- echo ' "DownloadWorkers" : 4,'
- echo ' "UploadWorkers" : 4,'
- echo ' "SkipSameSize" : true,'
- echo ' "Verbose" : 1'
- echo "}"
-}