summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNOGISAKA Sadata2015-06-09 22:58:28 +0900
committerNOGISAKA Sadata2015-06-09 22:58:28 +0900
commitab3b93b593c395c4798f87e81719f7058e96a89a (patch)
tree8d52bf88cfd1325366ad79e7a351320618d9bde9
downloadaur-megam.tar.gz
initial import
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD34
-rw-r--r--megam.patch48
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03e861ddd64d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = megam
+ pkgdesc = MEGA Model Optimization Package
+ pkgver = 0.92
+ pkgrel = 4
+ url = http://www.umiacs.umd.edu/~hal/megam/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = ocaml
+ source = http://hal3.name/megam/megam_src.tgz
+ source = megam.patch
+ md5sums = a8b02d3b62933e2a7fb1f4412840a431
+ md5sums = 0d79ac56e89615028895b8f5a4df4c27
+
+pkgname = megam
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..aa1ec1ea0618
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tgz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26ffc122bee6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: nosada <ngsksdt@gmail.com>
+
+pkgname=megam
+pkgver=0.92
+pkgrel=4
+pkgdesc="MEGA Model Optimization Package"
+url='http://www.umiacs.umd.edu/~hal/megam/'
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('ocaml')
+source=('http://hal3.name/megam/megam_src.tgz'
+ 'megam.patch') # patch for Makefile which is to resolve the error while building
+md5sums=('a8b02d3b62933e2a7fb1f4412840a431'
+ '0d79ac56e89615028895b8f5a4df4c27')
+
+build() {
+ cd ${srcdir}/megam_${pkgver}
+
+ patch < ${srcdir}/megam.patch
+ sed -n '/This code/,/ webpage./p' README > LICENSE
+ make
+ # According to README, building by "make" makes binary safe but slow.
+ # if you want fast but not so safe binary, please uncomment below.
+ #make opt
+}
+
+package() {
+ cd ${srcdir}/megam_${pkgver}
+
+ install -D -m775 megam ${pkgdir}/usr/bin/megam
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/megam.patch b/megam.patch
new file mode 100644
index 000000000000..baa707c12a9e
--- /dev/null
+++ b/megam.patch
@@ -0,0 +1,48 @@
+--- Makefile 2007-10-09 02:06:04.000000000 +0900
++++ Makefile.modified 2013-03-16 23:45:19.420694775 +0900
+@@ -55,19 +55,19 @@
+
+ # Default setting of the WITH* variables. Should be changed if your
+ # local libraries are not found by the compiler.
+-WITHGRAPHICS =graphics.cma -cclib -lgraphics -cclib -L/usr/X11R6/lib -cclib -lX11
++WITHGRAPHICS =graphics.cma
+
+-WITHUNIX =unix.cma -cclib -lunix
++WITHUNIX =unix.cma
+
+-WITHSTR =str.cma -cclib -lstr
++WITHSTR =str.cma
+
+-WITHBIGARRAY =bigarray.cma -cclib -lbigarray
++WITHBIGARRAY =bigarray.cma
+
+-WITHNUMS =nums.cma -cclib -lnums
++WITHNUMS =nums.cma
+
+-WITHTHREADS =threads.cma -cclib -lthreads
++WITHTHREADS =threads.cma
+
+-WITHDBM =dbm.cma -cclib -lmldbm -cclib -lndbm
++WITHDBM =dbm.cma
+
+ #WITHCLIBS =-I /usr/lib/ocaml/3.09.2/caml
+ WITHCLIBS =-I /usr/lib/ocaml/caml
+@@ -84,12 +84,12 @@
+
+ opt : $(EXEC).opt
+
+-#ocamlc -custom other options graphics.cma other files -cclib -lgraphics -cclib -lX11
+-#ocamlc -thread -custom other options threads.cma other files -cclib -lthreads
+-#ocamlc -custom other options str.cma other files -cclib -lstr
+-#ocamlc -custom other options nums.cma other files -cclib -lnums
+-#ocamlc -custom other options unix.cma other files -cclib -lunix
+-#ocamlc -custom other options dbm.cma other files -cclib -lmldbm -cclib -lndbm
++#ocamlc -custom other options graphics.cma other files
++#ocamlc -thread -custom other options threads.cma other files
++#ocamlc -custom other options str.cma other files
++#ocamlc -custom other options nums.cma other files
++#ocamlc -custom other options unix.cma other files
++#ocamlc -custom other options dbm.cma other files
+
+ SOURCES1 = $(SOURCES:.mly=.ml)
+ SOURCES2 = $(SOURCES1:.mll=.ml)