summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Roth2020-02-10 16:13:50 +0100
committerMichael Roth2020-02-10 16:13:50 +0100
commit46218d05a84f7ff93fc8d8d0e7939d99ecd7ba5d (patch)
treedf216378a2edc51b9aa356259ccb5b786c072ec5
downloadaur-46218d05a84f7ff93fc8d8d0e7939d99ecd7ba5d.tar.gz
Initial commit, tested locally and works
-rw-r--r--.SRCINFO42
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD40
-rw-r--r--megaman-rocknroll.desktop35
-rw-r--r--megaman-rocknroll.install14
-rw-r--r--mmrnr.pngbin0 -> 1317 bytes
6 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9fdc061dac1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,42 @@
+pkgbase = megaman-rocknroll
+ pkgdesc = MegaMan based fan game made with Godot
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://dennisengelhard.com/rock-n-roll/
+ install = megaman-rocknroll.install
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = dbus
+ depends = flac
+ depends = gcc-libs
+ depends = glibc
+ depends = libasyncns
+ depends = libgcrypt
+ depends = libglvnd
+ depends = libgpg-error
+ depends = libogg
+ depends = libpulse
+ depends = libsndfile
+ depends = libvorbis
+ depends = libxau
+ depends = libxcb
+ depends = libxcursor
+ depends = libxdmcp
+ depends = libxext
+ depends = libxfixes
+ depends = libxinerama
+ depends = libxrandr
+ depends = libxrender
+ depends = lz4
+ depends = systemd-libs
+ depends = xz
+ source = https://dennisengelhard.files.wordpress.com/2020/02/megaman_rocknroll_linux_1.2.zip
+ source = megaman-rocknroll.desktop
+ source = mmrnr.png
+ sha256sums = b3a77e09ecda0b49538403e294af8a92e04f46b746d99eae7466b858f0d35eb8
+ sha256sums = 8fe73015af3b6f684f278b0f6aa274f82ca78f80264f2e3af2cc96145075fb0a
+ sha256sums = 93d862cacc440d79434450e345cfcdf7e84791bd550ea0ccb234acd9a0d62613
+
+pkgname = megaman-rocknroll
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..22a175d06188
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+
+megaman_rocknroll_linux_*.zip
+megaman-rocknroll-*-x86_64.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17cb1e3b4508
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Michael Roth <mail.michael.roth+aur@gmail.com>
+pkgname=megaman-rocknroll
+pkgver=1.2
+pkgrel=1
+
+pkgdesc="MegaMan based fan game made with Godot"
+url="https://dennisengelhard.com/rock-n-roll/"
+license=('custom')
+
+arch=('x86_64')
+
+install=megaman-rocknroll.install
+
+#Original dependencies found by ldd
+#depends=('alsa-lib' 'dbus' 'flac' 'gcc-libs' 'glibc' 'libasyncns' 'libgcrypt' 'libglvnd' 'libgpg-error' 'libogg' 'libpulse' 'libsndfile' 'libvorbis' 'libxau' 'libxcb' 'libxcursor' 'libxdmcp' 'libxext' 'libxfixes' 'libxinerama' 'libxrandr' 'libxrender' 'lz4' 'systemd-libs' 'xz')
+
+depends=('alsa-lib' 'dbus' 'flac' 'gcc-libs' 'glibc' 'libasyncns' 'libgcrypt' 'libglvnd' 'libgpg-error' 'libogg' 'libpulse' 'libsndfile' 'libvorbis' 'libxau' 'libxcb' 'libxcursor' 'libxdmcp' 'libxext' 'libxfixes' 'libxinerama' 'libxrandr' 'libxrender' 'lz4' 'systemd-libs' 'xz')
+
+source=("https://dennisengelhard.files.wordpress.com/2020/02/megaman_rocknroll_linux_${pkgver}.zip"
+ megaman-rocknroll.desktop
+ mmrnr.png
+)
+
+sha256sums=('b3a77e09ecda0b49538403e294af8a92e04f46b746d99eae7466b858f0d35eb8'
+ '8fe73015af3b6f684f278b0f6aa274f82ca78f80264f2e3af2cc96145075fb0a'
+ '93d862cacc440d79434450e345cfcdf7e84791bd550ea0ccb234acd9a0d62613')
+
+
+
+package() {
+ # Install Game executable and data files
+ install -D -m 755 "${srcdir}/MegaMan_RocknRoll" "${pkgdir}/opt/megaman-rocknroll/MegaMan_RocknRoll"
+ install -D -m 644 "${srcdir}/data.pck" "${pkgdir}/opt/megaman-rocknroll/data.pck"
+
+ # Install icon
+ install -D -m 644 "${srcdir}/mmrnr.png" "${pkgdir}/usr/share/icons/hicolor/64x64/apps/mmrnr.png"
+
+ # Install .desktop file
+ install -D -m 644 "${srcdir}/megaman-rocknroll.desktop" "${pkgdir}/usr/share/applications/megaman-rocknroll.desktop"
+}
diff --git a/megaman-rocknroll.desktop b/megaman-rocknroll.desktop
new file mode 100644
index 000000000000..5f4d16de18ae
--- /dev/null
+++ b/megaman-rocknroll.desktop
@@ -0,0 +1,35 @@
+[Desktop Entry]
+
+# The type as listed above
+Type=Application
+
+# The version of the desktop entry specification to which this file complies
+Version=1.2
+
+# The name of the application
+Name=MegaMan - Rock n Roll
+
+# A comment which can/will be used as a tooltip
+Comment=A MegaMan based fan game made with Godot
+
+Name[en_GB]=MegaMan - Rock n Roll
+Comment[en_GB]=A MegaMan based fan game made with Godot
+
+Name[de]=MegaMan - Rock n Roll
+Comment[de]=Ein MegaMan basiertes Fan Game erstellt mit Godot
+
+
+# The path to the folder in which the executable is run
+Path=/opt/megaman-rocknroll/
+
+# The executable of the application, possibly with arguments.
+Exec=MegaMan_RocknRoll
+
+# The name of the icon that will be used to display this entry
+Icon=mmrnr
+
+# Describes whether this application needs to be run in a terminal or not
+Terminal=false
+
+# Describes the categories in which this entry should be shown
+Categories=Game
diff --git a/megaman-rocknroll.install b/megaman-rocknroll.install
new file mode 100644
index 000000000000..d918fdf1b40c
--- /dev/null
+++ b/megaman-rocknroll.install
@@ -0,0 +1,14 @@
+post_upgrade() {
+ post_install $1
+}
+
+post_install() {
+ echo ">>> "
+ echo ">>> Have fun playing!"
+ echo ">>> Savegames and config files can be found in ~/.godot/app_userdata/Megaman_RnR/"
+ echo ">>> "
+}
+
+op=$1
+shift
+$op $*
diff --git a/mmrnr.png b/mmrnr.png
new file mode 100644
index 000000000000..17d4b58c1191
--- /dev/null
+++ b/mmrnr.png
Binary files differ