summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafał Kozdrój2020-03-05 16:43:39 +0100
committerRafał Kozdrój2020-03-05 16:44:48 +0100
commit119c9384cea121ab80f140f45be2d08d8a0844eb (patch)
treef4c4a99868d6b72cc2bf12e1872dd613d46ba6e5
parentfa6fd326f88fed89ea570e31930711d3ca7e2f67 (diff)
downloadaur-119c9384cea121ab80f140f45be2d08d8a0844eb.tar.gz
upgpkg: megasync 4.3.0.8-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--fix-double-declaration-of-tgkill.patch26
-rw-r--r--pdfium.patch16
4 files changed, 33 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 670991c3a53a..c83378a17f40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = megasync
pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive
- pkgver = 4.2.5
- pkgrel = 4
+ pkgver = 4.3.0.8
+ pkgrel = 1
url = https://github.com/meganz/MEGAsync
arch = i686
arch = x86_64
@@ -21,13 +21,13 @@ pkgbase = megasync
depends = libraw
depends = qt5-base
depends = ffmpeg
- optdepends = sni-qt: fix systray issue on KDE and LXQt
- source = git+https://github.com/meganz/MEGAsync.git#tag=v4.2.5.0_Linux
+ depends = libpdfium
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v4.3.0.8_Linux
source = meganz-sdk::git+https://github.com/meganz/sdk.git
- source = fix-double-declaration-of-tgkill.patch
+ source = pdfium.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = a4ee87777bc055bc98dc9b044734d24e0ec17124389fedcf45e6a67cfe2fb061
+ sha256sums = f913ff490771e170610829f42f9285412ed8f4e7343f5dd7cb33e3bda4175aba
pkgname = megasync
diff --git a/PKGBUILD b/PKGBUILD
index a0aa15af69e9..e7bfcc96cb04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,31 +6,31 @@
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=megasync
-pkgver=4.2.5
-pkgrel=4
+pkgver=4.3.0.8
+pkgrel=1
pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive"
arch=('i686' 'x86_64')
url="https://github.com/meganz/MEGAsync"
license=('custom:MEGA LIMITED CODE REVIEW LICENCE')
depends=('c-ares' 'crypto++' 'libsodium' 'hicolor-icon-theme' 'libuv'
- 'qt5-svg' 'libmediainfo' 'libraw' 'qt5-base' 'ffmpeg')
+ 'qt5-svg' 'libmediainfo' 'libraw' 'qt5-base' 'ffmpeg' 'libpdfium')
makedepends=('qt5-tools' 'swig' 'doxygen' 'lsb-release' 'git')
-optdepends=('sni-qt: fix systray issue on KDE and LXQt')
-_extname=".0_Linux"
+_extname="_Linux"
source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}${_extname}"
"meganz-sdk::git+https://github.com/meganz/sdk.git"
- "fix-double-declaration-of-tgkill.patch")
+ "pdfium.patch")
sha256sums=('SKIP'
'SKIP'
- 'a4ee87777bc055bc98dc9b044734d24e0ec17124389fedcf45e6a67cfe2fb061')
+ 'f913ff490771e170610829f42f9285412ed8f4e7343f5dd7cb33e3bda4175aba')
prepare() {
cd "MEGAsync"
git submodule init
git config submodule.src/MEGASync/mega.url "../meganz-sdk"
git submodule update
-
- patch -Np1 -i "../fix-double-declaration-of-tgkill.patch"
+
+ cd "src/MEGASync/mega"
+ patch -Np1 -i "../../../../pdfium.patch"
}
build() {
@@ -71,7 +71,8 @@ package () {
install -Dm 644 src/MEGASync/mega/LICENSE "${pkgdir}/usr/share/licenses/megasync/SDK-LICENCE"
cd "src"
- make INSTALL_ROOT="${pkgdir}" install
+ mkdir -pm 755 "${pkgdir}/usr/bin"
+ make INSTALL_ROOT="${pkgdir}" TARGET="${pkgdir}/usr/bin/megasync" install
install -Dm 755 "MEGASync/megasync" "${pkgdir}/usr/bin/megasync"
}
diff --git a/fix-double-declaration-of-tgkill.patch b/fix-double-declaration-of-tgkill.patch
deleted file mode 100644
index beeea5d1b413..000000000000
--- a/fix-double-declaration-of-tgkill.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/src/MEGASync/google_breakpad/client/linux/handler/exception_handler.cc b/src/MEGASync/google_breakpad/client/linux/handler/exception_handler.cc
-index 48f91682..1b7ed059 100644
---- a/src/MEGASync/google_breakpad/client/linux/handler/exception_handler.cc
-+++ b/src/MEGASync/google_breakpad/client/linux/handler/exception_handler.cc
-@@ -103,12 +103,6 @@
- #define PR_SET_PTRACER 0x59616d61
- #endif
-
--// A wrapper for the tgkill syscall: send a signal to a specific thread.
--static int tgkill(pid_t tgid, pid_t tid, int sig) {
-- return syscall(__NR_tgkill, tgid, tid, sig);
-- return 0;
--}
--
- namespace google_breakpad {
-
- namespace {
-@@ -347,7 +341,7 @@ void ExceptionHandler::SignalHandler(int sig, siginfo_t* info, void* uc) {
- // In order to retrigger it, we have to queue a new signal by calling
- // kill() ourselves. The special case (si_pid == 0 && sig == SIGABRT) is
- // due to the kernel sending a SIGABRT from a user request via SysRQ.
-- if (tgkill(getpid(), syscall(__NR_gettid), sig) < 0) {
-+ if (sys_tgkill(getpid(), syscall(__NR_gettid), sig) < 0) {
- // If we failed to kill ourselves (e.g. because a sandbox disallows us
- // to do so), we instead resort to terminating our process. This will
- // result in an incorrect exit code.
diff --git a/pdfium.patch b/pdfium.patch
new file mode 100644
index 000000000000..478ba46c20e7
--- /dev/null
+++ b/pdfium.patch
@@ -0,0 +1,16 @@
+diff --git a/bindings/qt/sdk.pri b/bindings/qt/sdk.pri
+index aa68cb00d..1d495d78f 100644
+--- a/bindings/qt/sdk.pri
++++ b/bindings/qt/sdk.pri
+@@ -206,6 +206,11 @@ CONFIG(USE_PDFIUM) {
+ DEFINES += HAVE_PDFIUM
+ LIBS += -lpdfium
+ }
++ else:exists(/usr/include/pdfium/fpdfview.h) {
++ DEFINES += HAVE_PDFIUM
++ INCLUDEPATH += /usr/include/pdfium
++ LIBS += -lpdfium
++ }
+ }
+ else {#win/mac
+ DEFINES += HAVE_PDFIUM