summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2023-10-28 07:46:21 -0300
committerDaniel Bermond2023-10-28 07:46:21 -0300
commited64108af521b4c8a5149dd7fe8ee9d6d6dc58e8 (patch)
treef1083a250e0e0ceaf064ef4b4030d08f0c160143
parent1b7947b66a435fe48aa2a42a7e61d34bcf82f54e (diff)
downloadaur-ed64108af521b4c8a5149dd7fe8ee9d6d6dc58e8.tar.gz
Update to version 4.10.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--010-megasync-libpdfium.patch2
-rw-r--r--PKGBUILD10
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44aee1912b45..58656870c479 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = megasync
pkgdesc = Official MEGA desktop application for syncing with MEGA Cloud Drive
- pkgver = 4.9.5.0
+ pkgver = 4.10.0.0
pkgrel = 1
- url = https://github.com/meganz/MEGAsync
+ url = https://github.com/meganz/MEGAsync/
arch = x86_64
license = custom
makedepends = git
@@ -30,13 +30,13 @@ pkgbase = megasync
depends = sqlite
depends = zlib
depends = hicolor-icon-theme
- source = git+https://github.com/meganz/MEGAsync.git#tag=v4.9.5.0_Linux
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v4.10.0.0_OSX
source = meganz-sdk::git+https://github.com/meganz/sdk.git
source = 010-megasync-libpdfium.patch
source = 020-megasync-ffmpeg.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = d42ce082425c4b730f6d75de1c4914b02af0ab8993cd9dd65bde389469dfe500
+ sha256sums = a6435d56b5f7493474ee74c735a880b1d72f802fb3bab8824c497642c784ac0e
sha256sums = 49690421d98e8f61a600ee1ec97adc3e4d1cbe2f736fcf56056da23d02db378b
pkgname = megasync
diff --git a/010-megasync-libpdfium.patch b/010-megasync-libpdfium.patch
index e0f29f4be82d..16879c949ff8 100644
--- a/010-megasync-libpdfium.patch
+++ b/010-megasync-libpdfium.patch
@@ -1,6 +1,6 @@
--- a/bindings/qt/sdk.pri
+++ b/bindings/qt/sdk.pri
-@@ -290,6 +290,11 @@ CONFIG(USE_PDFIUM) {
+@@ -292,6 +292,11 @@ CONFIG(USE_PDFIUM) {
DEFINES += HAVE_PDFIUM
LIBS += -lpdfium
}
diff --git a/PKGBUILD b/PKGBUILD
index 40e9a356767e..a35dd01c1bff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,28 +7,28 @@
# Contributor: Hexchain Tong <i at hexchain dot org>
pkgname=megasync
-pkgver=4.9.5.0
+pkgver=4.10.0.0
pkgrel=1
pkgdesc='Official MEGA desktop application for syncing with MEGA Cloud Drive'
arch=('x86_64')
-url='https://github.com/meganz/MEGAsync'
+url='https://github.com/meganz/MEGAsync/'
license=('custom')
depends=('c-ares' 'crypto++' 'curl' 'ffmpeg' 'freeimage' 'icu' 'libmediainfo'
'libpdfium' 'libsodium' 'libudev.so' 'libuv' 'libxcb' 'libzen' 'openssl'
'qt5-base' 'qt5-svg' 'qt5-x11extras' 'sqlite' 'zlib' 'hicolor-icon-theme')
makedepends=('git' 'doxygen' 'lsb-release' 'qt5-tools' 'swig')
-source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_Linux"
+source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}_OSX"
'meganz-sdk'::'git+https://github.com/meganz/sdk.git'
'010-megasync-libpdfium.patch'
'020-megasync-ffmpeg.patch')
sha256sums=('SKIP'
'SKIP'
- 'd42ce082425c4b730f6d75de1c4914b02af0ab8993cd9dd65bde389469dfe500'
+ 'a6435d56b5f7493474ee74c735a880b1d72f802fb3bab8824c497642c784ac0e'
'49690421d98e8f61a600ee1ec97adc3e4d1cbe2f736fcf56056da23d02db378b')
prepare() {
git -C MEGAsync submodule init
- git -C MEGAsync config submodule.src/MEGASync/mega.url "${srcdir}/meganz-sdk"
+ git -C MEGAsync config --local submodule.src/MEGASync/mega.url "${srcdir}/meganz-sdk"
git -C MEGAsync -c protocol.file.allow='always' submodule update
patch -d MEGAsync/src/MEGASync/mega -Np1 -i "${srcdir}/010-megasync-libpdfium.patch"