summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-01-09 09:55:10 +0100
committersL1pKn072017-01-09 09:55:10 +0100
commit2d5f2db4417af284ab8f9b012a9a5fb201b4ba49 (patch)
tree39a75da2db4608895b090d72ca44ee6d0be27aea
parentda4eac8facf9c6d9c0064bea69d971e93555e1a8 (diff)
downloadaur-2d5f2db4417af284ab8f9b012a9a5fb201b4ba49.tar.gz
bump
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 26 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cca5f413f0ff..5a135dcd8d17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jul 30 13:41:45 UTC 2016
+# Mon Jan 9 08:54:09 UTC 2017
pkgbase = megasync-git
pkgdesc = Sync your files to your Mega account. Official app. (GIT Version)
- pkgver = v2.9.8.0.10.g4977c8e
+ pkgver = v2.9.10.0.g2e03defa
pkgrel = 1
url = https://mega.co.nz/#sync
arch = i686
@@ -15,16 +15,17 @@ pkgbase = megasync-git
depends = libuv
depends = curl
depends = crypto++
+ depends = libsodium
depends = hicolor-icon-theme
- depends = xdg-utils
- depends = desktop-file-utils
provides = megasync
conflicts = megasync
conflicts = megatools
- source = megasync::git+https://github.com/meganz/MEGAsync.git
+ source = git+https://github.com/meganz/MEGAsync.git
+ source = git+https://github.com/meganz/sdk.git
source = mega.svg
- sha1sums = SKIP
- sha1sums = f0ce3c0c3297cbb07f211a6ff2a0237823e0c9cd
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = c0abfeafb541509923c85d253f6f64dae8a49e9ae4b067f5c0c484ff1d924403
pkgname = megasync-git
diff --git a/PKGBUILD b/PKGBUILD
index a1e0094fdb15..2fcf3affd030 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
# Contributor: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
pkgname=megasync-git
-pkgver=v2.9.8.0.10.g4977c8e
+pkgver=v2.9.10.0.g2e03defa
pkgrel=1
pkgdesc="Sync your files to your Mega account. Official app. (GIT Version)"
arch=('i686' 'x86_64')
url='https://mega.co.nz/#sync'
license=('custom:MEGA')
-source=('megasync::git+https://github.com/meganz/MEGAsync.git'
+source=('git+https://github.com/meganz/MEGAsync.git'
+ 'git+https://github.com/meganz/sdk.git'
'mega.svg'
)
conflicts=('megasync'
@@ -20,46 +21,44 @@ depends=('qt5-base'
'libuv'
'curl'
'crypto++'
+ 'libsodium'
'hicolor-icon-theme'
- 'xdg-utils'
- 'desktop-file-utils'
)
makedepends=('git'
'qt5-tools'
)
-sha1sums=('SKIP'
- 'f0ce3c0c3297cbb07f211a6ff2a0237823e0c9cd'
- )
+sha256sums=('SKIP'
+ 'SKIP'
+ 'c0abfeafb541509923c85d253f6f64dae8a49e9ae4b067f5c0c484ff1d924403'
+ )
pkgver() {
- cd megasync
+ cd MEGAsync
echo "$(git describe --long --tags | tr - . | tr _ . | sed 's|OSX\.||' | sed 's|Win\.||' | sed 's|Linux\.||' )"
}
prepare() {
- cd megasync
+ cd MEGAsync
+ git config submodule.src/MEGASync/mega.url "${srcdir}/sdk"
git submodule update --init
cd src/MEGASync/mega
./autogen.sh
./configure \
- --disable-examples \
- --disable-posix-threads \
- --without-freeimage \
- --without-sodium
+ --without-freeimage
}
build() {
- cd megasync/src
- qmake-qt5 CONFIG+=release MEGA.pro
- lrelease-qt5 MEGASync/MEGASync.pro
+ cd MEGAsync/src/MEGASync
+ lrelease-qt5 MEGASync.pro
+ qmake-qt5 CONFIG+=release MEGASync.pro
make
}
package() {
- install -Dm644 megasync/LICENCE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm755 megasync/src/MEGASync/megasync "${pkgdir}/usr/bin/megasync"
- install -Dm644 megasync/src/MEGASync/platform/linux/data/megasync.desktop "${pkgdir}/usr/share/applications/megasync.desktop"
+ install -Dm644 MEGAsync/LICENCE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 MEGAsync/src/MEGASync/megasync "${pkgdir}/usr/bin/megasync"
+ install -Dm644 MEGAsync/src/MEGASync/platform/linux/data/megasync.desktop "${pkgdir}/usr/share/applications/megasync.desktop"
sed 's|System;||g' -i "${pkgdir}/usr/share/applications/megasync.desktop"
install -Dm644 "${srcdir}/mega.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/mega.svg"
}