summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-03-24 14:38:47 +0100
committerGustavo Alvarez2016-03-24 14:38:47 +0100
commit90dacfcb3e261079feef704218144769a96197b5 (patch)
tree9e90f6ed90d3ccbd41d554880fe96db3b54a429b
parent4c93dce618b7497cd61004f861619e673261d907 (diff)
downloadaur-90dacfcb3e261079feef704218144769a96197b5.tar.gz
Update pkgver=() method and edit some things
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
-rw-r--r--megasync.desktop14
4 files changed, 8 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a8284c3efd60..a5a416874983 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Mar 12 19:07:26 UTC 2016
+# Thu Mar 24 13:38:14 UTC 2016
pkgbase = megasync-git
pkgdesc = Sync your files to your Mega account. Official app. (GIT Version)
- pkgver = 2.7.1.1977.fd9cafb
+ pkgver = v2.8.0.0.Linux.0.gb029ac2
pkgrel = 1
url = https://mega.co.nz/#sync
install = megasync-git.install
@@ -21,10 +21,8 @@ pkgbase = megasync-git
conflicts = megasync
conflicts = megatools
source = megasync::git+https://github.com/meganz/MEGAsync.git
- source = megasync.desktop
source = mega.svg
sha1sums = SKIP
- sha1sums = 077e146596f6e31254675a1e0771ddcc05084f03
sha1sums = f0ce3c0c3297cbb07f211a6ff2a0237823e0c9cd
pkgname = megasync-git
diff --git a/.gitignore b/.gitignore
index 3853ff18a42d..d987188fba12 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,3 @@
!PKGBUILD
!megasync-git.install
!mega.svg
-!megasync.desktop
-
diff --git a/PKGBUILD b/PKGBUILD
index 819a4aa899f6..39e09a8a6f36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Contributor: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
pkgname=megasync-git
-pkgver=2.7.1.1977.fd9cafb
+pkgver=v2.8.0.0.Linux.0.gb029ac2
pkgrel=1
pkgdesc="Sync your files to your Mega account. Official app. (GIT Version)"
arch=('i686' 'x86_64')
url='https://mega.co.nz/#sync'
license=('custom:MEGA')
source=('megasync::git+https://github.com/meganz/MEGAsync.git'
- 'megasync.desktop'
'mega.svg'
)
conflicts=('megasync' 'megatools')
@@ -25,14 +24,13 @@ makedepends=('git'
'qt5-tools'
)
sha1sums=('SKIP'
- '077e146596f6e31254675a1e0771ddcc05084f03'
'f0ce3c0c3297cbb07f211a6ff2a0237823e0c9cd'
)
install=megasync-git.install
pkgver() {
cd megasync
- echo "$(< build/version).$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ echo "$(git describe --long --tags | tr - . | tr _ .)"
}
prepare() {
@@ -57,10 +55,9 @@ build() {
}
package() {
- cd megasync
- install -Dm644 LICENCE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd src/MEGASync
- install -Dm755 megasync "${pkgdir}/usr/bin/megasync"
- install -Dm644 "${srcdir}/megasync.desktop" "${pkgdir}/usr/share/applications/megasync.desktop"
+ install -Dm644 megasync/LICENCE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 megasync/src/MEGASync/megasync "${pkgdir}/usr/bin/megasync"
+ install -Dm644 megasync/src/MEGASync/platform/linux/data/megasync.desktop "${pkgdir}/usr/share/applications/megasync.desktop"
+ sed 's|System;||g' -i "${pkgdir}/usr/share/applications/megasync.desktop"
install -Dm644 "${srcdir}/mega.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/mega.svg"
}
diff --git a/megasync.desktop b/megasync.desktop
deleted file mode 100644
index 024828f5a3bf..000000000000
--- a/megasync.desktop
+++ /dev/null
@@ -1,14 +0,0 @@
-[Desktop Entry]
-Type=Application
-Version=1.0
-GenericName=File Synchronizer
-Name=MEGASync
-Comment=Easy automated syncing between your computers and your MEGA cloud drive.
-TryExec=megasync
-Exec=megasync
-Icon=mega
-Terminal=false
-Categories=Network;
-StartupNotify=false
-X-GNOME-Autostart-Delay=60
-