summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-03-12 19:33:23 +0100
committerGustavo Alvarez2016-03-12 19:35:57 +0100
commitf5aed788b4f7c7f04bb398ef2953eb98bf1e3896 (patch)
tree8d24c4aff12ee98ee6097862a4e301a4a69519b3
downloadaur-f5aed788b4f7c7f04bb398ef2953eb98bf1e3896.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD66
-rw-r--r--mega.svg10
-rw-r--r--megasync-git.install12
-rw-r--r--megasync.desktop14
6 files changed, 140 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4dfe77cfaede
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Sat Mar 12 18:33:23 UTC 2016
+pkgbase = megasync-git
+ pkgdesc = Sync your files to your Mega account. Official app. (GIT Version)
+ pkgver = 2.7.1.1977.fd9cafb
+ pkgrel = 1
+ url = https://mega.co.nz/#sync
+ install = megasync-git.install
+ arch = i686
+ arch = x86_64
+ license = custom:MEGA
+ makedepends = git
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = c-ares
+ depends = libuv
+ depends = curl
+ depends = crypto++
+ depends = hicolor-icon-theme
+ provides = megasync
+ conflicts = megasync
+ conflicts = megatools
+ source = megasync::git+https://github.com/meganz/MEGAsync.git
+ source = megasync.desktop
+ source = mega.svg
+ sha1sums = SKIP
+ sha1sums = 077e146596f6e31254675a1e0771ddcc05084f03
+ sha1sums = b4a4103dc922cbadf18fd1a74b4fa695a5a95235
+
+pkgname = megasync-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2ee4c8738eed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!mega.svg
+!megasync.desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..927ed00d1f6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
+
+pkgname=megasync-git
+pkgver=2.7.1.1977.fd9cafb
+pkgrel=1
+pkgdesc="Sync your files to your Mega account. Official app. (GIT Version)"
+arch=('i686' 'x86_64')
+url='https://mega.co.nz/#sync'
+license=('custom:MEGA')
+source=('megasync::git+https://github.com/meganz/MEGAsync.git'
+ 'megasync.desktop'
+ 'mega.svg'
+ )
+conflicts=('megasync' 'megatools')
+provides=('megasync')
+depends=('qt5-base'
+ 'c-ares'
+ 'libuv'
+ 'curl'
+ 'crypto++'
+ 'hicolor-icon-theme'
+ )
+makedepends=('git'
+ 'qt5-tools'
+ )
+sha1sums=('SKIP'
+ '077e146596f6e31254675a1e0771ddcc05084f03'
+ 'b4a4103dc922cbadf18fd1a74b4fa695a5a95235'
+ )
+install=megasync-git.install
+
+pkgver() {
+ cd megasync
+ echo "$(< build/version).$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd megasync
+ sed 's|git@github.com:meganz/sdk.git|https://github.com/meganz/sdk.git|g' -i .gitmodules
+ git submodule update --init --recursive
+
+ cd src/MEGASync/mega
+ ./autogen.sh
+ ./configure \
+ --disable-examples \
+ --disable-posix-threads \
+ --without-freeimage \
+ --without-sodium
+}
+
+build() {
+ cd megasync/src
+ qmake-qt5 CONFIG+=release MEGA.pro
+ lrelease-qt5 MEGASync/MEGASync.pro
+ make
+}
+
+package() {
+ cd megasync
+ install -Dm644 LICENCE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd src/MEGASync
+ install -Dm755 megasync "${pkgdir}/usr/bin/megasync"
+ install -Dm644 "${srcdir}/megasync.desktop" "${pkgdir}/usr/share/applications/megasync.desktop"
+ install -Dm644 "${srcdir}/mega.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/mega.svg"
+}
diff --git a/mega.svg b/mega.svg
new file mode 100644
index 000000000000..86470e7b0fc4
--- /dev/null
+++ b/mega.svg
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="iso-8859-1"?>
+<!-- Generator: Adobe Illustrator 16.0.0, SVG Export Plug-In . SVG Version: 6.00 Build 0) -->
+<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN" "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
+<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
+ width="721px" height="721px" viewBox="119.5 239.5 721 721" style="enable-background:new 119.5 239.5 721 721;"
+ xml:space="preserve">
+<circle style="fill:#D31B00;" cx="480" cy="600" r="360.5"/>
+<polygon style="fill:#FFFFFF;" points="267,454 352,454 480,584 609,454 691,454 691,747 605,747 605,577.25 500.334,682
+ 459.666,682 355,577.25 355,747 267,747 "/>
+</svg>
diff --git a/megasync-git.install b/megasync-git.install
new file mode 100644
index 000000000000..ec506fa9330b
--- /dev/null
+++ b/megasync-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/megasync.desktop b/megasync.desktop
new file mode 100644
index 000000000000..024828f5a3bf
--- /dev/null
+++ b/megasync.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+GenericName=File Synchronizer
+Name=MEGASync
+Comment=Easy automated syncing between your computers and your MEGA cloud drive.
+TryExec=megasync
+Exec=megasync
+Icon=mega
+Terminal=false
+Categories=Network;
+StartupNotify=false
+X-GNOME-Autostart-Delay=60
+