summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Menelkir2022-03-23 17:59:41 -0300
committerDaniel Menelkir2022-03-23 17:59:41 -0300
commit19b094efeed8ba3a27aeddbea5ded09ab16fcfbc (patch)
tree917bfa0af3ec2d9958b58a308f9dee58a3b2c40d
parent1cf01297c2562361c57bcf60495be1bc4db52149 (diff)
downloadaur-19b094efeed8ba3a27aeddbea5ded09ab16fcfbc.tar.gz
Update: 4.6.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD5
-rw-r--r--ffmpeg.patch18
3 files changed, 20 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0e1de95fbf0..5f029fa97203 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = megasync-nopdfium
pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive(stripped of pdfium dependency)
- pkgver = 4.6.1.0
+ pkgver = 4.6.5.0
pkgrel = 1
url = https://github.com/meganz/MEGAsync
arch = i686
@@ -23,13 +23,13 @@ pkgbase = megasync-nopdfium
depends = libraw
depends = ffmpeg
depends = freeimage
- provides = megasync=4.6.1.0
+ provides = megasync=4.6.5.0
conflicts = megasync
- source = git+https://github.com/meganz/MEGAsync.git#tag=v4.6.1.0_Win
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v4.6.5.0_Win
source = meganz-sdk::git+https://github.com/meganz/sdk.git
source = ffmpeg.patch
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 3a15322d39b7f69a21c866cd1965893c5c1b4285b1a079593a183aefcff0f8c2
+ sha256sums = bc8a8460c967d084e2643431dbb06c03897f1944a0e899318fc78b611f9255e6
pkgname = megasync-nopdfium
diff --git a/PKGBUILD b/PKGBUILD
index 3402081c859a..9022e4ad0af7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
#!/hint/bash
# Maintainer : bartus <arch-local-repo(at).bartus.33mail.com>
+# Contributor : Daniel Menelkir <dmenelkir@gmail.com>
# Contributor : Rafał Kozdrój <kozeid2+aur@gmail.com>
# Contributor : kikadf <kikadf.01@gmail.com>
# Contributor : Daniel Henry <d at hackr dot pl>
@@ -10,7 +11,7 @@
# shellcheck disable=SC2164 # cd safe
pkgname=megasync-nopdfium
-pkgver=4.6.1.0
+pkgver=4.6.5.0
pkgrel=1
pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive(stripped of pdfium dependency)"
arch=('i686' 'x86_64')
@@ -28,7 +29,7 @@ source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}${_extname}"
"ffmpeg.patch")
sha256sums=('SKIP'
'SKIP'
- '3a15322d39b7f69a21c866cd1965893c5c1b4285b1a079593a183aefcff0f8c2')
+ 'bc8a8460c967d084e2643431dbb06c03897f1944a0e899318fc78b611f9255e6')
prepare() {
cd "MEGAsync"
diff --git a/ffmpeg.patch b/ffmpeg.patch
index 01e35b57c50f..036547f11ca5 100644
--- a/ffmpeg.patch
+++ b/ffmpeg.patch
@@ -1,8 +1,16 @@
-diff --git a/src/gfx/freeimage.cpp b/src/gfx/freeimage.cpp
-index 50271f9a9..e427b5e54 100644
---- a/src/gfx/freeimage.cpp
-+++ b/src/gfx/freeimage.cpp
-@@ -253,7 +253,6 @@ bool GfxProcFreeImage::readbitmapFfmpeg(FileAccess* fa, const LocalPath& imagePa
+diff --unified --recursive --text v4.6.2.0/src/gfx/freeimage.cpp v4.6.3.0/src/gfx/freeimage.cpp
+--- v4.6.2.0/src/gfx/freeimage.cpp 2022-02-05 23:51:36.555355000 +0800
++++ v4.6.3.0/src/gfx/freeimage.cpp 2022-02-06 00:21:20.888555180 +0800
+@@ -240,7 +240,7 @@
+
+ // Find decoder for video stream
+ AVCodecID codecId = codecParm->codec_id;
+- AVCodec* decoder = avcodec_find_decoder(codecId);
++ const AVCodec* decoder = avcodec_find_decoder(codecId);
+ if (!decoder)
+ {
+ LOG_warn << "Codec not found: " << codecId;
+@@ -257,7 +257,6 @@
// Force seeking to key frames
formatContext->seek2any = false;