summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfonso Saavedra Son2016-04-27 23:52:36 +0200
committerAlfonso Saavedra Son2016-04-27 23:52:36 +0200
commit4b8b17a1b991efe23e6ae5c98b1dd677d0ed5b88 (patch)
tree50fc4374fa2d05bdd2e9b05dac5d41cc2424eeb4
parent590671f7b9f65ff121824de976e759b656448c94 (diff)
downloadaur-4b8b17a1b991efe23e6ae5c98b1dd677d0ed5b88.tar.gz
Update to 2.9.1.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c31a67466bb2..a2c5a291d868 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Mar 26 10:48:18 UTC 2016
+# Wed Apr 27 21:51:49 UTC 2016
pkgbase = megasync
pkgdesc = Sync your files to your Mega account. Official app
- pkgver = 2.8.0
+ pkgver = 2.9.1.0
pkgrel = 1
url = https://mega.nz/#sync
install = megasync.install
@@ -21,11 +21,9 @@ pkgbase = megasync
depends = libuv
optdepends = sni-qt: fix systray issue on KDE and LXQt
conflicts = megatools
- source = git+https://github.com/meganz/MEGAsync.git#commit=cf855e49c945860a90d91fe67767956dcbeb923d
- source = git+https://github.com/meganz/sdk.git#commit=4ed589a68fdd3d9b170aef78b18c4c5753bb3f8f
+ source = git+https://github.com/meganz/MEGAsync.git#tag=v2_9_1_0_Linux
source = megasync.install
md5sums = SKIP
- md5sums = SKIP
md5sums = cf6fbb67643cc68baa8ea89bbd989fa0
pkgname = megasync
diff --git a/PKGBUILD b/PKGBUILD
index 381343ab69e6..f0a040469e3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Alfonso Saavedra "Son Link" <sonlink.dourden@gmail.com>
pkgname=megasync
-pkgver=2.8.0
+pkgver=2.9.1.0
+_pkgver=${pkgver//./_}
pkgrel=1
pkgdesc="Sync your files to your Mega account. Official app"
arch=('i686' 'x86_64')
@@ -10,19 +11,15 @@ conflicts=('megatools')
depends=('openssl' 'c-ares' 'libgcrypt' 'crypto++' 'qt4' 'libpng' 'qtchooser' 'sqlite' 'libuv')
makedepends=('git')
optdepends=('sni-qt: fix systray issue on KDE and LXQt')
-source=("git+https://github.com/meganz/MEGAsync.git#commit=cf855e49c945860a90d91fe67767956dcbeb923d"
- "git+https://github.com/meganz/sdk.git#commit=4ed589a68fdd3d9b170aef78b18c4c5753bb3f8f"
+source=("git+https://github.com/meganz/MEGAsync.git#tag=v${_pkgver}_Linux"
"megasync.install")
md5sums=('SKIP'
- 'SKIP'
'cf6fbb67643cc68baa8ea89bbd989fa0')
install="${pkgname}.install"
prepare(){
cd MEGAsync
- git submodule init
- git config submodule.src/MEGASync/mega.url "$srcdir/sdk"
- git submodule update
+ git submodule update --init --recursive
}
build(){