summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-09-01 20:38:50 +0200
committerbartus2020-09-01 20:38:50 +0200
commit7d483ad617a1f420b2a20ca1937ed82eabe2363d (patch)
treec508a6631c92684fe5280b71cd7f553a664eb0e9
parentedca2cb4e6db50f146a7ad3b392458f55f5a4575 (diff)
downloadaur-7d483ad617a1f420b2a20ca1937ed82eabe2363d.tar.gz
fix glibc:2.32 build
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c0bdd052367..82ea6648d1c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = megasync-nopdfium
pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive(stripped of pdfium dependency)
pkgver = 4.3.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/meganz/MEGAsync
arch = i686
arch = x86_64
@@ -25,8 +25,10 @@ pkgbase = megasync-nopdfium
conflicts = megasync
source = git+https://github.com/meganz/MEGAsync.git#tag=v4.3.3.0_Linux
source = meganz-sdk::git+https://github.com/meganz/sdk.git
+ source = glibc_232.patch::https://github.com/meganz/MEGAsync/pull/477.diff
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 5b7553fdf68d6350b7e255553285e002dc643f04e8aae9d891d0f9802f6cf27a
pkgname = megasync-nopdfium
diff --git a/PKGBUILD b/PKGBUILD
index 6d6d7b055fbe..e51380af4736 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=megasync-nopdfium
pkgver=4.3.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive(stripped of pdfium dependency)"
arch=('i686' 'x86_64')
provides=(megasync)
@@ -24,9 +24,11 @@ makedepends=('qt5-tools' 'swig' 'doxygen' 'lsb-release' 'git')
_extname="_Linux"
source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}${_extname}"
"meganz-sdk::git+https://github.com/meganz/sdk.git"
+ "glibc_232.patch::https://github.com/meganz/MEGAsync/pull/477.diff"
)
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '5b7553fdf68d6350b7e255553285e002dc643f04e8aae9d891d0f9802f6cf27a')
prepare() {
cd "MEGAsync"
@@ -37,6 +39,7 @@ prepare() {
cd "src/MEGASync"
sed -i '/DEFINES += REQUIRE_HAVE_PDFIUM/d' MEGASync.pro
sed -i '/CONFIG += USE_PDFIUM/d' MEGASync.pro
+ git apply -v "$srcdir"/glibc_232.patch
}
build() {