summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2020-06-07 23:50:52 +0200
committerbartus2020-06-07 23:51:42 +0200
commit9db13447167a4a7c6fa0ed8feae678d2ea0aecf6 (patch)
tree21c42550d3dc4dd14da50da60c731873a7426348
parent624cb2154c1adab6fbd070a38c2041f8d10d6860 (diff)
downloadaur-9db13447167a4a7c6fa0ed8feae678d2ea0aecf6.tar.gz
Fix build against qt5:5.15.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--qt5_5.15.patch24
3 files changed, 33 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d060ffe87e6e..93de7e928c6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = megasync-nopdfium
pkgdesc = Easy automated syncing between your computers and your MEGA cloud drive(stripped of pdfium dependency)
pkgver = 4.3.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/meganz/MEGAsync
arch = i686
arch = x86_64
@@ -25,8 +25,10 @@ pkgbase = megasync-nopdfium
conflicts = megasync
source = git+https://github.com/meganz/MEGAsync.git#tag=v4.3.1.0_Linux
source = meganz-sdk::git+https://github.com/meganz/sdk.git
+ source = qt5_5.15.patch
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 27cf5f69ed40ae02e2a4145ccb4931834a60c32d907b083e8b3db626c3062562
pkgname = megasync-nopdfium
diff --git a/PKGBUILD b/PKGBUILD
index f4df48a8ab79..308175438c9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+#!/hint/bash
# Maintainer : bartus <arch-local-repo(at).bartus.33mail.com>
# Contributor : Rafał Kozdrój <kozeid2+aur@gmail.com>
# Contributor : kikadf <kikadf.01@gmail.com>
@@ -10,7 +11,7 @@
pkgname=megasync-nopdfium
pkgver=4.3.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Easy automated syncing between your computers and your MEGA cloud drive(stripped of pdfium dependency)"
arch=('i686' 'x86_64')
provides=(megasync)
@@ -23,10 +24,11 @@ makedepends=('qt5-tools' 'swig' 'doxygen' 'lsb-release' 'git')
_extname="_Linux"
source=("git+https://github.com/meganz/MEGAsync.git#tag=v${pkgver}${_extname}"
"meganz-sdk::git+https://github.com/meganz/sdk.git"
+ "qt5_5.15.patch"
)
sha256sums=('SKIP'
'SKIP'
- )
+ '27cf5f69ed40ae02e2a4145ccb4931834a60c32d907b083e8b3db626c3062562')
prepare() {
cd "MEGAsync"
@@ -37,6 +39,8 @@ prepare() {
cd "src/MEGASync"
sed -i '/DEFINES += REQUIRE_HAVE_PDFIUM/d' MEGASync.pro
sed -i '/CONFIG += USE_PDFIUM/d' MEGASync.pro
+
+ git -C "$srcdir"/MEGAsync apply "$srcdir"/qt5_5.15.patch
}
build() {
diff --git a/qt5_5.15.patch b/qt5_5.15.patch
new file mode 100644
index 000000000000..509a97b1a386
--- /dev/null
+++ b/qt5_5.15.patch
@@ -0,0 +1,24 @@
+From 99295fc0b9858b08d379a86625902d92f5129542 Mon Sep 17 00:00:00 2001
+From: bartus <szczepaniak.bartek+github@gmail.com>
+Date: Sun, 7 Jun 2020 23:22:49 +0200
+Subject: [PATCH] Fix build against qt>=5.15
+
+---
+ src/MEGASync/gui/MegaSpeedGraph.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/MEGASync/gui/MegaSpeedGraph.h b/src/MEGASync/gui/MegaSpeedGraph.h
+index d98f582a..b7ffbcbb 100644
+--- a/src/MEGASync/gui/MegaSpeedGraph.h
++++ b/src/MEGASync/gui/MegaSpeedGraph.h
+@@ -2,6 +2,7 @@
+ #define MEGASPEEDGRAPH_H
+
+ #include <QWidget>
++#include <QPainterPath>
+ #include "megaapi.h"
+
+ namespace Ui {
+--
+2.27.0
+