summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordangersalad2018-06-28 23:15:53 -0600
committerdangersalad2018-06-28 23:15:53 -0600
commit31bd3f835d95ade677514ccbe9d3a7bd74cbe1fc (patch)
tree5947d839fad4a5643d862c5914ec8fa072821354
parent806dc6b81ca9c122c94998969683b22b28004c0e (diff)
downloadaur-31bd3f835d95ade677514ccbe9d3a7bd74cbe1fc.tar.gz
update to 0.44.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--megamek.sh5
-rw-r--r--mekhq.sh5
4 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f829726c7aa1..74bd452c10f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mekhq
pkgdesc = MekHQ is a java helper program for the MegaMek game that allows users to load a list of entities from an XML file, perform repairs and customizations, and then save the new entities to another XML file that can be loaded into MegaMek.
- pkgver = 0.43.11
+ pkgver = 0.44.0
pkgrel = 1
url = https://github.com/MegaMek/mekhq
arch = x86_64
@@ -8,20 +8,20 @@ pkgbase = mekhq
depends = jdk10-openjdk
provides = megamek
conflicts = megamek
- source = https://github.com/MegaMek/mekhq/releases/download/v0.43.11/mekhq-0.43.11-RC5.tar.gz
+ source = https://github.com/MegaMek/mekhq/releases/download/v0.44.0/mekhq-0.44.0.tar.gz
source = mekhq.desktop
source = megamek.desktop
source = mm-startup.patch
source = mm-server.patch
source = mekhq.sh
source = megamek.sh
- sha256sums = 6a458dcf7d6379af3f574daa1213b10abb96a4c73a3e0bd9454d0280ee2c6caf
+ sha256sums = 2e51546d94e58532fcfaf1481f15da862b8d70c741687cb4a149f171cca6f08a
sha256sums = a6c0cc72c6f3ad773bdcec24c8036ae7d09dcaea4908f5b6d4e5ac6091cff772
sha256sums = caf5bf3e7294029c7b6dec974eed0253d6caf3804a6a9fcc953edc3c9be98b16
sha256sums = 113d6fe539108d172db238abd6a316be55d6d1af92cf0bcb4555b7cb70427908
sha256sums = b964aa25672d5311b98f51ae7e895f32501092bcd5382979a4af45ba3436b5ba
- sha256sums = 7134a0a0b0622abb935cea12ebe5347f1ff00b92b30f74d2b27aa2ade931bdda
- sha256sums = 9ce5b4d9f299e47de57efe1bd3bdca488079a3a3f0b7da43a55b687d9692f6d5
+ sha256sums = 056b528fb478966d32eaa36354335f667a73776975ebf57794f4f992e72f41c3
+ sha256sums = 7c1988808f166dca21732a6d5679acdeb55520e3bb4babcc0b0b7c1e8b671f52
pkgname = mekhq
diff --git a/PKGBUILD b/PKGBUILD
index b7eba3679fc4..e7914457167b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Paul Davis <paul@dangersalad.com>
pkgname=mekhq
-pkgver=0.43.11
-_pkgver=-RC5
+pkgver=0.44.0
+_pkgver=
pkgrel=1
epoch=
pkgdesc="MekHQ is a java helper program for the MegaMek game that allows users to load a list of entities from an XML file, perform repairs and customizations, and then save the new entities to another XML file that can be loaded into MegaMek."
@@ -22,13 +22,13 @@ source=("https://github.com/MegaMek/mekhq/releases/download/v${pkgver}/${pkgname
"mekhq.sh"
"megamek.sh")
-sha256sums=('6a458dcf7d6379af3f574daa1213b10abb96a4c73a3e0bd9454d0280ee2c6caf'
+sha256sums=('2e51546d94e58532fcfaf1481f15da862b8d70c741687cb4a149f171cca6f08a'
'a6c0cc72c6f3ad773bdcec24c8036ae7d09dcaea4908f5b6d4e5ac6091cff772'
'caf5bf3e7294029c7b6dec974eed0253d6caf3804a6a9fcc953edc3c9be98b16'
'113d6fe539108d172db238abd6a316be55d6d1af92cf0bcb4555b7cb70427908'
'b964aa25672d5311b98f51ae7e895f32501092bcd5382979a4af45ba3436b5ba'
- '7134a0a0b0622abb935cea12ebe5347f1ff00b92b30f74d2b27aa2ade931bdda'
- '9ce5b4d9f299e47de57efe1bd3bdca488079a3a3f0b7da43a55b687d9692f6d5')
+ '056b528fb478966d32eaa36354335f667a73776975ebf57794f4f992e72f41c3'
+ '7c1988808f166dca21732a6d5679acdeb55520e3bb4babcc0b0b7c1e8b671f52')
package() {
diff --git a/megamek.sh b/megamek.sh
index d717cea29e80..b4b2a9e6517c 100644
--- a/megamek.sh
+++ b/megamek.sh
@@ -12,9 +12,6 @@ then
mkdir -p "$conf"
fi
-if [[ ! -d "$conf/mmconf" ]]
-then
- cp -af /usr/lib/mekhq/* "$conf/"
-fi
+rsync -avc /usr/lib/mekhq/ "$conf/"
exec env MEGAMEK_CONFPATH="$conf" "$conf/mm-startup.sh"
diff --git a/mekhq.sh b/mekhq.sh
index d4651ce9922a..59bf5a869de6 100644
--- a/mekhq.sh
+++ b/mekhq.sh
@@ -12,9 +12,6 @@ then
mkdir -p "$conf"
fi
-if [[ ! -d "$conf/mmconf" ]]
-then
- cp -af /usr/lib/mekhq/* "$conf/"
-fi
+rsync -avc /usr/lib/mekhq/ "$conf/"
exec env MEGAMEK_CONFPATH="$conf" "$conf/hq.sh"