summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormydongistiny2016-03-31 20:34:53 -0700
committermydongistiny2016-03-31 20:45:38 -0700
commitb2791fc29c6ea236badaff214933e5469da78a8b (patch)
tree39f6f38501ccb5bf7dc56b3cf6a0e886da7f1e6d
parenta492c8aa27a83d8967aec3aa24cf32267d802243 (diff)
downloadaur-b2791fc29c6ea236badaff214933e5469da78a8b.tar.gz
Fixed again. Last time
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25dbf12f9ace..49462c64e150 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = meld-dev
pkgdesc = Visual diff and merge tool
pkgver = 3.15.2
- pkgrel = 3
+ pkgrel = 4
url = http://meldmerge.org/
install = meld.install
arch = any
@@ -19,7 +19,8 @@ pkgbase = meld-dev
optdepends = python2-dbus: open a new tab in an already running instance
optdepends = python2-gconf: gnome integration
provides = meld
- conflicts = meld
+ conflicts = meld meld-git
+ replaces = meld meld-git
options = !emptydirs
source = http://ftp.gnome.org/pub/GNOME/sources/meld/3.15/meld-3.15.2.tar.xz
sha1sums = c5c34f52ebe337c654ad5e35450f43e95bdd7743
diff --git a/PKGBUILD b/PKGBUILD
index 10b9c152c761..189558132921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,38 @@
# Maintainer: Jason Edson <jason@oceighty.co>
-pkgname=meld
+_pkgname=meld
+pkgname=$_pkgname-dev
pkgver=3.15.2
-pkgrel=3
+pkgrel=4
pkgdesc='Visual diff and merge tool'
url='http://meldmerge.org/'
license=(GPL)
arch=(any)
+conflicts=('meld','meld-git')
+replaces=('meld','meld-git')
+provides=('meld')
makedepends=(intltool itstool)
install=meld.install
depends=(python2-gobject python2-cairo gtksourceview3 hicolor-icon-theme desktop-file-utils
gsettings-desktop-schemas)
optdepends=('python2-dbus: open a new tab in an already running instance')
-source=("https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.xz")
+source=("https://download.gnome.org/sources/$_pkgname/${pkgver%.*}/meld-${pkgver}.tar.xz")
sha1sums=('c5c34f52ebe337c654ad5e35450f43e95bdd7743')
# Meld does not support Python 3. The build succeeds, but
# the main executable checks the version and errors out.
prepare() {
- cd $pkgname-$pkgver
+ cd $_pkgname-$pkgver
}
build() {
- cd $pkgname-$pkgver
+ cd $_pkgname-$pkgver
python2 setup.py build
}
package() {
- cd $pkgname-$pkgver
+ cd $_pkgname-$pkgver
# using --skip-build breaks install
python2 setup.py --no-update-icon-cache --no-compile-schemas \
install --prefix=/usr --root="$pkgdir" --optimize=1