summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormydongistiny2020-05-06 12:26:27 -0700
committermydongistiny2020-05-06 12:28:45 -0700
commit7a8ebe24200e81f94445f3d8cf4dfaa9c2fc80a5 (patch)
tree4a6de728202d66b9e412992d1885327712432587
parent0a672f5c24ebe094930e7dd43dd2f6004709d9b8 (diff)
downloadaur-7a8ebe24200e81f94445f3d8cf4dfaa9c2fc80a5.tar.gz
Disable python byte-compile for package
Not needed when packaging and causes errors like: Compiling '/usr/lib/python3.8/site-packages/meld/ui/__init__.py'... *** PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.8/site-packages/meld/ui/__pycache__'
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2298a0e9593e..55ef3fde5480 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = meld-git
pkgdesc = Visual diff and merge tool
- pkgver = 3.20.0.485.gff5916e7
+ pkgver = 3.21.0.2.g3b682e16
pkgrel = 1
url = http://meldmerge.org/
install = meld.install
diff --git a/PKGBUILD b/PKGBUILD
index af116b916001..1c8355b7913a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=meld
pkgname=$_pkgname-git
-pkgver=3.20.0.485.gff5916e7
+pkgver=3.21.0.2.g3b682e16
pkgrel=1
_realver=3.21.0
pkgdesc='Visual diff and merge tool'
@@ -41,7 +41,7 @@ prepare() {
build() {
cd "$srcdir/$_pkgname"
- arch-meson build -D docs=true
+ arch-meson build -D docs=true -D byte-compile=false
ninja -C build
}