summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaptainYukinoshitaHachiman2022-06-04 11:24:25 +0800
committerCaptainYukinoshitaHachiman2022-06-04 11:24:25 +0800
commitaf6cddcfe7ebe6b4cfffed3fea939e132be0898e (patch)
tree28729d239b5ec6ca898c408433b8018060de9f34
parent3dd2d0bea5b19044938af30ae195417f4f91557d (diff)
downloadaur-af6cddcfe7ebe6b4cfffed3fea939e132be0898e.tar.gz
Move npm i to prepare, and refine the expressions in the wrapper
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
-rwxr-xr-xginkou-loader-wrapper2
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 465de0fca912..4d5cda94d255 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,6 @@ pkgbase = mellis
source = git+https://github.com/themeliolabs/mellis.git#tag=v0.3.6
source = file://ginkou-loader-wrapper
sha256sums = SKIP
- sha256sums = c067389bd0331916456c40f7806e7b1203b44edeb57ec3e4c7667badea2b2e05
+ sha256sums = ab8068086631322ff4f85ae126d2a7e0c0cc30b33ec2ff42849d48c454ed3863
pkgname = mellis
diff --git a/PKGBUILD b/PKGBUILD
index a911e291f689..0144a090d6d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ source=(
"file://ginkou-loader-wrapper"
)
sha256sums=(
- 'SKIP' 'c067389bd0331916456c40f7806e7b1203b44edeb57ec3e4c7667badea2b2e05'
+ 'SKIP' 'ab8068086631322ff4f85ae126d2a7e0c0cc30b33ec2ff42849d48c454ed3863'
)
prepare() {
@@ -21,7 +21,11 @@ prepare() {
git submodule init
git submodule update
- cd "ginkou-loader"
+ cd "ginkou"
+ rm package-lock.json
+ npm i
+
+ cd "../ginkou-loader"
cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
@@ -30,15 +34,13 @@ build() {
# build web assets
cd "ginkou"
- rm package-lock.json
- npm i
npm run build
# build loader
cd "../ginkou-loader"
export RUSTUP_TOOLCHAIN=stable
- export CARGO_TARGET_DIR=target
- cargo build --frozen --release --all-features
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
}
package() {
diff --git a/ginkou-loader-wrapper b/ginkou-loader-wrapper
index 150c44079029..8cafb070db4d 100755
--- a/ginkou-loader-wrapper
+++ b/ginkou-loader-wrapper
@@ -1,3 +1,3 @@
#!/bin/sh
if [[ -z "${XDG_DATA_HOME}" ]]; then CONFIG="${HOME}/.config/mellis"; else CONFIG="${XDG_DATA_HOME}/mellis"; fi;
-ginkou-loader --html-path /usr/share/mellis/public --data-path $CONFIG/.config/mellis/ginkou-storage --wallet-path $CONFIG/.config/mellis/themelio-wallets --melwalletd-path /usr/bin/melwalletd
+ginkou-loader --html-path "/usr/share/mellis/public" --data-path "${CONFIG}/.config/mellis/ginkou-storage" --wallet-path "${CONFIG}/.config/mellis/themelio-wallets" --melwalletd-path "/usr/bin/melwalletd"