summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Duquesnoy2018-01-14 19:17:10 +0100
committerColin Duquesnoy2018-01-14 19:17:10 +0100
commit020823ee4405714942abf5203c1406cce8661313 (patch)
tree85904e9494dfec10527e30ef5ea6a4f9ba371435
parent9cf0219aba17b5d06fa73ea186490afa64a4dcdb (diff)
downloadaur-020823ee4405714942abf5203c1406cce8661313.tar.gz
mellowplayer 3.3.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c179b47ff8f..89ca5fd4870d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mellowplayer
pkgdesc = Open source and cross-platform desktop application that runs web-based music streaming services in its own window and provides integration with your desktop.
- pkgver = 3.3.0
+ pkgver = 3.3.1
pkgrel = 1
url = https://github.com/ColinDuquesnoy/MellowPlayer
arch = x86_64
@@ -19,9 +19,9 @@ pkgbase = mellowplayer
depends = libevent
optdepends = qt5-webengine-widevine: widevine DRM plugin
optdepends = pepper-flash: needed for Deezer and Spotify
- source = https://github.com/ColinDuquesnoy/MellowPlayer/archive/3.3.0.tar.gz
+ source = https://github.com/ColinDuquesnoy/MellowPlayer/archive/3.3.1.tar.gz
source = widevine-path.patch
- md5sums = b60e420b011936bd60279669fedae75b
+ md5sums = 9be9e5d3cc61c0472feb4d861d0cca51
md5sums = 67f8c5c6af4b770a4017a5ca9f137b90
pkgname = mellowplayer
diff --git a/PKGBUILD b/PKGBUILD
index a99616019e9a..c7dea124141d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Colin Duquesnoy <colin.duquesnoy@gmail.com>
# Maintainer: ZeroDot1 <zerodot1@bk.ru>
pkgname=mellowplayer
-pkgver=3.3.0
+pkgver=3.3.1
pkgrel=1
pkgdesc="Open source and cross-platform desktop application that runs web-based music streaming
services in its own window and provides integration with your desktop."
@@ -13,22 +13,21 @@ makedepends=('qt5-tools' 'cmake')
optdepends=( 'qt5-webengine-widevine: widevine DRM plugin' 'pepper-flash: needed for Deezer and Spotify')
source=("https://github.com/ColinDuquesnoy/MellowPlayer/archive/${pkgver}.tar.gz"
"widevine-path.patch")
-md5sums=('b60e420b011936bd60279669fedae75b'
+md5sums=('9be9e5d3cc61c0472feb4d861d0cca51'
'67f8c5c6af4b770a4017a5ca9f137b90')
-
+
prepare() {
cd $srcdir/MellowPlayer-${pkgver}
patch -Np1 -i "${srcdir}/widevine-path.patch" "$srcdir/MellowPlayer-${pkgver}/src/main/share/applications/mellowplayer.desktop"
- mkdir build
}
build() {
- cd $srcdir/MellowPlayer-${pkgver}/build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib ..
+ cd $srcdir/MellowPlayer-${pkgver}
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
make
}
package() {
- cd $srcdir/MellowPlayer-${pkgver}/build
+ cd $srcdir/MellowPlayer-${pkgver}
make DESTDIR=${pkgdir} install
}