summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColinDuquesnoy2017-12-18 21:32:35 +0100
committerColinDuquesnoy2017-12-18 21:32:35 +0100
commit0601cd7a41e990d11582f71c07e07ebd331fafb2 (patch)
tree94e4ce151f2804118ea71b07443ab6e8fc0445eb
parentd231467caf46ae1df623fe1a62c488f6026e978c (diff)
downloadaur-0601cd7a41e990d11582f71c07e07ebd331fafb2.tar.gz
patch for ppapi-widevine-path
-rw-r--r--PKGBUILD14
-rw-r--r--mellowplayer.install16
-rw-r--r--widevine-path.patch11
3 files changed, 22 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c2237190a52..c55ca12b3a20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: ZeroDot1 <zerodot1@bk.ru>
pkgname=mellowplayer
pkgver=3.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Open source and cross-platform desktop application that runs web-based music streaming
services in its own window and provides integration with your desktop."
url='https://github.com/ColinDuquesnoy/MellowPlayer'
@@ -11,12 +11,20 @@ arch=('x86_64')
depends=('qt5-base' 'qt5-webengine' 'qt5-svg' 'qt5-quickcontrols2' 'qt5-quickcontrols' 'qt5-translations' 'qt5-graphicaleffects' 'xdg-utils' 'libnotify' 'libevent')
makedepends=('qt5-tools' 'cmake')
optdepends=( 'qt5-webengine-widevine: widevine DRM plugin' 'pepper-flash: needed for Deezer and Spotify')
-source=("https://github.com/ColinDuquesnoy/MellowPlayer/archive/${pkgver}.tar.gz")
-md5sums=('3b139359978faed0282328b7edc545ea')
+source=("https://github.com/ColinDuquesnoy/MellowPlayer/archive/${pkgver}.tar.gz"
+ "widevine-path.patch")
+md5sums=('3b139359978faed0282328b7edc545ea'
+ '67f8c5c6af4b770a4017a5ca9f137b90')
+
+prepare() {
+ cd $srcdir/MellowPlayer-${pkgver}
+ patch -Np1 -i "${srcdir}/widevine-path.patch" "$srcdir/MellowPlayer-${pkgver}/src/share/applications/mellowplayer.desktop"
+}
build() {
cd $srcdir/MellowPlayer-${pkgver}
+ # patch -Np1 -i "${srcdir}/eject.patch"
cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -Wno-dev
make
}
diff --git a/mellowplayer.install b/mellowplayer.install
deleted file mode 100644
index 254471508dbe..000000000000
--- a/mellowplayer.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- echo "update desktop mime database..."
- update-desktop-database
- gtk-update-icon-cache -f /usr/share/icons/hicolor/
-}
-
-post_upgrade() {
- gtk-update-icon-cache -f /usr/share/icons/hicolor/
-}
-
-post_remove() {
- echo "update desktop mime database..."
- update-desktop-database
- gtk-update-icon-cache -f /usr/share/icons/hicolor/
-}
-
diff --git a/widevine-path.patch b/widevine-path.patch
new file mode 100644
index 000000000000..f63bd6fbfe1f
--- /dev/null
+++ b/widevine-path.patch
@@ -0,0 +1,11 @@
+--- src/share/applications/mellowplayer.desktop 2017-12-18 19:35:26.705475288 +0100
++++ src/share/applications/mellowplayer.desktop 2017-12-18 21:19:48.807747384 +0100
+@@ -3,7 +3,7 @@
+ Version=1.0
+ Type=Application
+ Name=MellowPlayer
+-Exec=MellowPlayer
++Exec=MellowPlayer --ppapi-widevine-path=/usr/lib/qt/plugins/ppapi/libwidevinecdmadapter.so
+ TryExec=MellowPlayer
+ Icon=mellowplayer
+ Terminal=false