summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Duquesnoy2019-03-10 13:25:26 +0100
committerColin Duquesnoy2019-03-10 13:25:26 +0100
commit27a677401818852898ad14ba888507a9371e2082 (patch)
treea4cda53a1022f7040651bd635b887354ac3bd1a5
parent3056bb3483c3006295ca337c0cd3ac962d3bcf9c (diff)
downloadaur-27a677401818852898ad14ba888507a9371e2082.tar.gz
MellowPlayer 3.5.3 + switch to ninja-build
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c348999a5193..7708644be961 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = mellowplayer
pkgdesc = Open source and cross-platform desktop application that runs web-based music streaming services in its own window and provides integration with your desktop.
- pkgver = 3.5.2
- pkgrel = 2
+ pkgver = 3.5.3
+ pkgrel = 1
url = https://github.com/ColinDuquesnoy/MellowPlayer
arch = x86_64
license = GPL
makedepends = qt5-tools
makedepends = cmake
makedepends = mesa
+ makedepends = ninja
depends = qt5-base
depends = qt5-webengine
depends = qt5-svg
@@ -18,11 +19,11 @@ pkgbase = mellowplayer
depends = xdg-utils
depends = libnotify
depends = libevent
- optdepends = qt5-webengine-widevine: DRM needed for Spotify
- optdepends = pepper-flash: needed for Tidal and Deezer
- source = https://gitlab.com/ColinDuquesnoy/MellowPlayer/-/archive/3.5.2/MellowPlayer-3.5.2.tar.gz
+ optdepends = qt5-webengine-widevine: DRM needed for Spotify and Amazon Music
+ optdepends = pepper-flash: needed for Tidal
+ source = https://gitlab.com/ColinDuquesnoy/MellowPlayer/-/archive/3.5.3/MellowPlayer-3.5.3.tar.gz
source = widevine-path.patch
- md5sums = 604a33c9f3608ee7403675969c1de902
+ md5sums = 4a6f6d7207664716938b3c9af5ff9194
md5sums = 67f8c5c6af4b770a4017a5ca9f137b90
pkgname = mellowplayer
diff --git a/PKGBUILD b/PKGBUILD
index f842316777a5..20925f2eb83c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Maintainer: ZeroDot1 <zerodot1@bk.ru>
pkgname=mellowplayer
_pkgname=MellowPlayer
-pkgver=3.5.2
-pkgrel=2
+pkgver=3.5.3
+pkgrel=1
pkgdesc="Open source and cross-platform desktop application that runs web-based music streaming
services in its own window and provides integration with your desktop."
url='https://github.com/ColinDuquesnoy/MellowPlayer'
license=('GPL')
arch=('x86_64')
depends=('qt5-base' 'qt5-webengine' 'qt5-svg' 'qt5-quickcontrols2' 'qt5-quickcontrols' 'qt5-translations' 'qt5-graphicaleffects' 'xdg-utils' 'libnotify' 'libevent')
-makedepends=('qt5-tools' 'cmake' 'mesa')
-optdepends=( 'qt5-webengine-widevine: DRM needed for Spotify' 'pepper-flash: needed for Tidal and Deezer')
+makedepends=('qt5-tools' 'cmake' 'mesa' 'ninja')
+optdepends=( 'qt5-webengine-widevine: DRM needed for Spotify and Amazon Music' 'pepper-flash: needed for Tidal')
source=("https://gitlab.com/ColinDuquesnoy/MellowPlayer/-/archive/${pkgver}/MellowPlayer-${pkgver}.tar.gz"
"widevine-path.patch")
-md5sums=('604a33c9f3608ee7403675969c1de902'
+md5sums=('4a6f6d7207664716938b3c9af5ff9194'
'67f8c5c6af4b770a4017a5ca9f137b90')
prepare() {
@@ -24,13 +24,12 @@ prepare() {
build() {
cd $srcdir/MellowPlayer-${pkgver}
- export MAKEFLAGS="-j$(nproc)"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib .
- make
+ cmake -GNinja -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" .
+ ninja
}
package() {
cd $srcdir/MellowPlayer-${pkgver}
- make DESTDIR=${pkgdir} install
+ ninja install
}