summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZeroDot12017-08-20 14:27:01 +0200
committerZeroDot12017-08-20 14:27:01 +0200
commit3620796cf9f3c5098696a191ae198d56b109068c (patch)
treefeb8964939d6a2a053040def00723391f273ec34
parent077fd305dc67dc363afc0753a1dcf3198016ea13 (diff)
downloadaur-3620796cf9f3c5098696a191ae198d56b109068c.tar.gz
Update to Version 3.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b48d38290606..2f78b798862f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,28 @@
# Generated by mksrcinfo v8
-# Sat Jun 17 13:54:50 UTC 2017
+# Sat Aug 19 21:54:52 UTC 2017
pkgbase = mellowplayer
pkgdesc = Open source and cross-platform desktop application that runs web-based music streaming services in its own window and provides integration with your desktop.
- pkgver = 2.2.5
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/ColinDuquesnoy/MellowPlayer
- install = mellowplayer.install
- arch = i686
arch = x86_64
license = GPL
makedepends = qt5-tools
+ makedepends = cmake
depends = qt5-base
depends = qt5-webengine
depends = qt5-svg
- depends = snorenotify
+ depends = qt5-quickcontrols2
+ depends = qt5-quickcontrols
+ depends = qt5-translations
+ depends = qt5-graphicaleffects
+ depends = xdg-utils
+ depends = libnotify
+ depends = libevent
+ optdepends = chromium-widevine: widevine DRM plugin
optdepends = pepper-flash: needed for Deezer and Spotify
- source = https://github.com/ColinDuquesnoy/MellowPlayer/archive/2.2.5.tar.gz
- md5sums = 69b77b15c83d92d67b50120556eec6d5
+ source = https://github.com/ColinDuquesnoy/MellowPlayer/archive/3.0.0.tar.gz
+ md5sums = e079f0714df0844600bf303639fe5757
pkgname = mellowplayer
diff --git a/PKGBUILD b/PKGBUILD
index cd2d699a2ea0..37ab37c708a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,31 @@
# Maintainer: Colin Duquesnoy <colin.duquesnoy@gmail.com>
+# Maintainer: ZeroDot1 <zerodot1@bk.ru>
pkgname=mellowplayer
-pkgver=2.2.5
+pkgver=3.0.0
pkgrel=1
pkgdesc="Open source and cross-platform desktop application that runs web-based music streaming
services in its own window and provides integration with your desktop."
url='https://github.com/ColinDuquesnoy/MellowPlayer'
license=('GPL')
-arch=('i686' 'x86_64')
-depends=('qt5-base' 'qt5-webengine' 'qt5-svg' 'snorenotify')
-makedepends=('qt5-tools')
-optdepends=('pepper-flash: needed for Deezer and Spotify')
+arch=('x86_64')
+depends=('qt5-base' 'qt5-webengine' 'qt5-svg' 'qt5-quickcontrols2' 'qt5-quickcontrols' 'qt5-translations' 'qt5-graphicaleffects' 'xdg-utils' 'libnotify' 'libevent')
+makedepends=('qt5-tools' 'cmake')
+optdepends=( 'chromium-widevine: widevine DRM plugin' 'pepper-flash: needed for Deezer and Spotify')
source=("https://github.com/ColinDuquesnoy/MellowPlayer/archive/${pkgver}.tar.gz")
-install="mellowplayer.install"
-md5sums=('69b77b15c83d92d67b50120556eec6d5')
+md5sums=('e079f0714df0844600bf303639fe5757')
build() {
cd $srcdir/MellowPlayer-${pkgver}
- mkdir build
- cd build
- qmake-qt5 ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_TESTING=OFF
make
}
package() {
- cd $srcdir/MellowPlayer-${pkgver}/build
+ cd $srcdir/MellowPlayer-${pkgver}
- make INSTALL_ROOT=${pkgdir} install
-}
+ make DESTDIR=${pkgdir} install
+} \ No newline at end of file