summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColinDuquesnoy2015-09-08 15:50:15 +0200
committerColinDuquesnoy2015-09-08 15:50:15 +0200
commit638234a225a3828b381cef74f8a44c7a846fed67 (patch)
treed0cc699e227501a5c15c116dd1a1f86f681a21a3
downloadaur-638234a225a3828b381cef74f8a44c7a846fed67.tar.gz
Version 1.5.0 for non-kde desktops
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD29
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..933f76c56612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mellowplayer
+ pkgdesc = Open source and cross-platform desktop application that runs web-based music streaming services in its own window and provides integration with your desktop.
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/ColinDuquesnoy/MellowPlayer
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-tools
+ depends = libnotify
+ optdepends = flashplugin: needed for Deezer, MixCloud, SoundCloud Music Service
+ conflicts = mellowplayer
+ source = https://github.com/ColinDuquesnoy/MellowPlayer/tarball/master/MellowPlayer-1.5.0.tar.gz
+ md5sums = 423620354f5534de16fcc0e3f3b4794a
+
+pkgname = mellowplayer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d1ed880f1dda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Colin Duquesnoy <colin.duquesnoy@gmail.com>
+pkgname=mellowplayer
+pkgver=1.5.0
+_commit=84af1a0
+pkgrel=1
+pkgdesc="Open source and cross-platform desktop application that runs web-based music streaming
+ services in its own window and provides integration with your desktop."
+url='https://github.com/ColinDuquesnoy/MellowPlayer'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('libnotify')
+makedepends=('qt5-tools')
+optdepends=('flashplugin: needed for Deezer, MixCloud, SoundCloud Music Service')
+conflicts=('mellowplayer')
+source=("https://github.com/ColinDuquesnoy/MellowPlayer/tarball/master/MellowPlayer-${pkgver}.tar.gz")
+md5sums=('423620354f5534de16fcc0e3f3b4794a')
+
+build() {
+ cd $srcdir/ColinDuquesnoy-MellowPlayer-${_commit}
+
+ qmake-qt5
+ make
+}
+
+package() {
+ cd $srcdir/ColinDuquesnoy-MellowPlayer-${_commit}
+
+ make INSTALL_ROOT=${pkgdir} install
+}