summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Duquesnoy2016-01-30 18:04:24 +0100
committerColin Duquesnoy2016-01-30 18:04:24 +0100
commit9dbdf99114cd472cd1059b517949f3e0f4c3d20b (patch)
treea99e9d502d78a1bc1250c3ac56d7df99826dd467
parent638234a225a3828b381cef74f8a44c7a846fed67 (diff)
downloadaur-9dbdf99114cd472cd1059b517949f3e0f4c3d20b.tar.gz
MellowPlayer 1.5.2 + .install + .gitignore
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD12
-rw-r--r--mellowplayer.install16
3 files changed, 26 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..520a12c87615
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index d1ed880f1dda..b3de0a782f6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: Colin Duquesnoy <colin.duquesnoy@gmail.com>
pkgname=mellowplayer
-pkgver=1.5.0
-_commit=84af1a0
+pkgver=1.5.2
pkgrel=1
pkgdesc="Open source and cross-platform desktop application that runs web-based music streaming
services in its own window and provides integration with your desktop."
@@ -12,18 +11,19 @@ depends=('libnotify')
makedepends=('qt5-tools')
optdepends=('flashplugin: needed for Deezer, MixCloud, SoundCloud Music Service')
conflicts=('mellowplayer')
-source=("https://github.com/ColinDuquesnoy/MellowPlayer/tarball/master/MellowPlayer-${pkgver}.tar.gz")
-md5sums=('423620354f5534de16fcc0e3f3b4794a')
+source=("https://github.com/ColinDuquesnoy/MellowPlayer/archive/${pkgver}.tar.gz")
+md5sums=('070f4e84111dd5998bf5b30e73e0d43a')
+install="mellowplayer.install"
build() {
- cd $srcdir/ColinDuquesnoy-MellowPlayer-${_commit}
+ cd $srcdir/MellowPlayer-${pkgver}
qmake-qt5
make
}
package() {
- cd $srcdir/ColinDuquesnoy-MellowPlayer-${_commit}
+ cd $srcdir/MellowPlayer-${pkgver}
make INSTALL_ROOT=${pkgdir} install
}
diff --git a/mellowplayer.install b/mellowplayer.install
new file mode 100644
index 000000000000..254471508dbe
--- /dev/null
+++ b/mellowplayer.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "update desktop mime database..."
+ update-desktop-database
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_upgrade() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+
+post_remove() {
+ echo "update desktop mime database..."
+ update-desktop-database
+ gtk-update-icon-cache -f /usr/share/icons/hicolor/
+}
+