summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColinDuquesnoy2017-12-18 21:09:19 +0100
committerColinDuquesnoy2017-12-18 21:09:19 +0100
commitd231467caf46ae1df623fe1a62c488f6026e978c (patch)
tree9709329527f79f5a709d5e40584d0f13eec15334
parent519d177eaeffc4c364c55cdf1d24ab6495fa18d9 (diff)
downloadaur-d231467caf46ae1df623fe1a62c488f6026e978c.tar.gz
mellowplayer 3.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1422d0e6b979..7eac4b10d9d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 21 16:08:15 UTC 2017
+# Mon Dec 18 20:06:13 UTC 2017
pkgbase = mellowplayer
pkgdesc = Open source and cross-platform desktop application that runs web-based music streaming services in its own window and provides integration with your desktop.
- pkgver = 3.1.0
+ pkgver = 3.2.0
pkgrel = 1
url = https://github.com/ColinDuquesnoy/MellowPlayer
arch = x86_64
@@ -21,8 +21,8 @@ pkgbase = mellowplayer
depends = libevent
optdepends = qt5-webengine-widevine: widevine DRM plugin
optdepends = pepper-flash: needed for Deezer and Spotify
- source = https://github.com/ColinDuquesnoy/MellowPlayer/archive/3.1.0.tar.gz
- md5sums = 0ea11e6574b7f4e56d8150c42762ec7f
+ source = https://github.com/ColinDuquesnoy/MellowPlayer/archive/3.2.0.tar.gz
+ md5sums = 3b139359978faed0282328b7edc545ea
pkgname = mellowplayer
diff --git a/PKGBUILD b/PKGBUILD
index 036a6d57d6b8..2c2237190a52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Colin Duquesnoy <colin.duquesnoy@gmail.com>
# Maintainer: ZeroDot1 <zerodot1@bk.ru>
pkgname=mellowplayer
-pkgver=3.1.0
+pkgver=3.2.0
pkgrel=1
pkgdesc="Open source and cross-platform desktop application that runs web-based music streaming
services in its own window and provides integration with your desktop."
@@ -12,15 +12,12 @@ depends=('qt5-base' 'qt5-webengine' 'qt5-svg' 'qt5-quickcontrols2' 'qt5-quickcon
makedepends=('qt5-tools' 'cmake')
optdepends=( 'qt5-webengine-widevine: widevine DRM plugin' 'pepper-flash: needed for Deezer and Spotify')
source=("https://github.com/ColinDuquesnoy/MellowPlayer/archive/${pkgver}.tar.gz")
-md5sums=('0ea11e6574b7f4e56d8150c42762ec7f')
+md5sums=('3b139359978faed0282328b7edc545ea')
build() {
cd $srcdir/MellowPlayer-${pkgver}
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_TESTING=OFF
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib -Wno-dev
make
}
@@ -28,4 +25,4 @@ package() {
cd $srcdir/MellowPlayer-${pkgver}
make DESTDIR=${pkgdir} install
-} \ No newline at end of file
+}