summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2019-12-02 19:10:31 +0100
committerTérence Clastres2019-12-02 19:10:31 +0100
commit4d699079c13afbe4c8974884c44e83f6079e31f6 (patch)
tree5d89ac8e370c64af06d32cbeac1a96bad63b3823
parentb04064891cf45fdcd5ff6e3ae359a3320595385c (diff)
downloadaur-4d699079c13afbe4c8974884c44e83f6079e31f6.tar.gz
Sync to https://aur.archlinux.org/packages/mellowplayer
- Update URL - Update makedepends,depends and optdepends - Change git describe to get un-annoted tags - Add aarch64 to arch() - Update build process
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0225f7865672..a874e1bdefd9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,16 @@
pkgbase = mellowplayer-git
pkgdesc = Open source and cross-platform desktop application that runs web-based music streaming services in its own window and provides integration with your desktop.
- pkgver = 3.0.0.r432.4ecdcde0
+ pkgver = 3.5.6.r4.gba304af5
pkgrel = 1
- url = https://github.com/ColinDuquesnoy/MellowPlayer
+ url = https://gitlab.com/ColinDuquesnoy/MellowPlayer
arch = x86_64
+ arch = aarch64
license = GPL
makedepends = qt5-tools
+ makedepends = cmake
+ makedepends = mesa
+ makedepends = ninja
+ makedepends = pkgconf
depends = qt5-base
depends = qt5-webengine
depends = qt5-svg
@@ -16,12 +21,11 @@ pkgbase = mellowplayer-git
depends = xdg-utils
depends = libnotify
depends = libevent
- depends = qbs
- optdepends = qt5-webengine-widevine: DRM needed for Spotify
- optdepends = pepper-flash: needed for Tidal and Deezer
+ optdepends = chromium-widevine: DRM needed for Spotify and Amazon Music
+ optdepends = pepper-flash: needed for Tidal
provides = mellowplayer
conflicts = mellowplayer
- source = git://github.com/ColinDuquesnoy/MellowPlayer
+ source = git+https://gitlab.com/ColinDuquesnoy/MellowPlayer.git
source = widevine-patch.patch
md5sums = SKIP
md5sums = 67f8c5c6af4b770a4017a5ca9f137b90
diff --git a/PKGBUILD b/PKGBUILD
index c21c9ae23445..81c2271810cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,44 +4,40 @@
pkgname=mellowplayer-git
_pkgname=MellowPlayer
-pkgver=3.0.0.r432.4ecdcde0
+pkgver=3.5.6.r4.gba304af5
pkgrel=1
pkgdesc='Open source and cross-platform desktop application that runs web-based music streaming
services in its own window and provides integration with your desktop.'
-url='https://github.com/ColinDuquesnoy/MellowPlayer'
+url='https://gitlab.com/ColinDuquesnoy/MellowPlayer'
license=(GPL)
conflicts=(mellowplayer)
provides=(mellowplayer)
-arch=(x86_64)
-depends=(qt5-base qt5-webengine qt5-svg qt5-quickcontrols2 qt5-quickcontrols qt5-translations qt5-graphicaleffects xdg-utils libnotify libevent qbs)
-makedepends=(qt5-tools)
-optdepends=('qt5-webengine-widevine: DRM needed for Spotify' 'pepper-flash: needed for Tidal and Deezer')
-source=('git://github.com/ColinDuquesnoy/MellowPlayer'
+arch=('x86_64' 'aarch64')
+depends=('qt5-base' 'qt5-webengine' 'qt5-svg' 'qt5-quickcontrols2' 'qt5-quickcontrols' 'qt5-translations' 'qt5-graphicaleffects' 'xdg-utils' 'libnotify' 'libevent')
+makedepends=('qt5-tools' 'cmake' 'mesa' 'ninja' 'pkgconf')
+optdepends=( 'chromium-widevine: DRM needed for Spotify and Amazon Music' 'pepper-flash: needed for Tidal')
+source=("git+$url.git"
'widevine-patch.patch')
md5sums=('SKIP'
'67f8c5c6af4b770a4017a5ca9f137b90')
pkgver() {
cd "${srcdir}/${_pkgname}"
- echo "$(git describe --always | sed 's/^v//; s/-/.r/; s/-g/./')"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "${srcdir}/${_pkgname}"
patch -Np1 -i "${srcdir}/widevine-patch.patch" "${srcdir}/${_pkgname}/src/main/share/applications/mellowplayer.desktop"
-
- qbs-setup-toolchains --detect
- qbs-setup-qt $(which qmake) qt5
- qbs-config defaultProfile qt5
}
build() {
cd "${srcdir}/${_pkgname}"
- qbs build config:release
+ cmake -GNinja -DCMAKE_INSTALL_LIBDIR=lib -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" .
+ ninja
}
package() {
cd "${srcdir}/${_pkgname}"
- qbs install --install-root "${pkgdir}/usr" config:release
+ ninja install
}
-# vim:set ts=2 sw=2 et: