summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorwin Kuiper2021-01-18 02:18:47 +0000
committerCorwin Kuiper2021-01-18 02:18:47 +0000
commit41a444fd1a5a6d25290d0ece8c7391ea53e2024e (patch)
treeeb64c2b63a5baed639917bb5001a48d47f7e158b
downloadaur-41a444fd1a5a6d25290d0ece8c7391ea53e2024e.tar.gz
0.9.1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50769155c207
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = melonds
+ pkgdesc = DS emulator, sorta. also 1st quality melon.
+ pkgver = 0.9.1
+ pkgrel = 1
+ url = http://melonds.kuribo64.net/
+ arch = i686
+ arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPLv3
+ makedepends = cmake
+ makedepends = pkg-config
+ depends = sdl2
+ depends = libslirp
+ depends = qt5-base
+ source = https://github.com/Arisotura/melonDS/archive/0.9.1.tar.gz
+ sha256sums = 9c7253a8c9bdd1270c142077eaa3a830176eef42123c72dc68cb1d4abd2d43a6
+
+pkgname = melonds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9161575688e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Corwin <corwin@kuiper.dev>
+
+pkgname=melonds
+pkgver=0.9.1
+pkgdesc='DS emulator, sorta'
+pkgrel=1
+arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="http://melonds.kuribo64.net/"
+license=('GPLv3')
+makedepends=('cmake' 'pkg-config')
+depends=('sdl2' 'libslirp' 'qt5-base')
+source=("https://github.com/Arisotura/melonDS/archive/$pkgver.tar.gz")
+
+sha256sums=('9c7253a8c9bdd1270c142077eaa3a830176eef42123c72dc68cb1d4abd2d43a6')
+
+build() {
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+ cd build
+ cmake ../melonDS-$pkgver \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make VERBOSE=ON
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+} \ No newline at end of file