summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarrison2022-03-09 00:10:02 -0500
committerHarrison2022-03-09 00:10:02 -0500
commit88204d8e3fb4d60b56169858865ab6cf9f67ada4 (patch)
tree8774834a53689e46567e520da18ada14ca48d212
parent7ec835fd238ddefdd6930bc6522fef1185f58497 (diff)
downloadaur-88204d8e3fb4d60b56169858865ab6cf9f67ada4.tar.gz
Update to 0.9.4, use VCS
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71ac2a9af259..b9c50ef09d3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = melonds
pkgdesc = DS emulator, sorta
- pkgver = 0.9.3
+ pkgver = 0.9.4
pkgrel = 1
url = http://melonds.kuribo64.net/
- arch = i686
arch = x86_64
+ arch = i686
+ arch = pentium4
arch = arm
arch = armv6h
arch = armv7h
arch = aarch64
- license = GPLv3
+ license = GPL3
makedepends = cmake
makedepends = pkg-config
- depends = sdl2
+ depends = libepoxy
depends = libslirp
depends = qt5-base
- depends = libepoxy
- source = https://github.com/Arisotura/melonDS/archive/0.9.3.tar.gz
- sha256sums = c50a3855c1f77f58a2b15045687dc399b845224a970fe68ff95919c939ac634f
+ depends = sdl2
+ source = git+https://github.com/Arisotura/melonDS.git#tag=0.9.4
+ sha256sums = SKIP
pkgname = melonds
diff --git a/PKGBUILD b/PKGBUILD
index a1fec52d8ef4..cc5705aa8b70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,30 @@
# Maintainer: Corwin <corwin@kuiper.dev>
+# Maintainer: Harrison <htv04rules at gmail dot com>
pkgname=melonds
-pkgver=0.9.3
-pkgdesc='DS emulator, sorta'
+pkgver=0.9.4
pkgrel=1
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+pkgdesc="DS emulator, sorta"
+arch=("x86_64" "i686" "pentium4" "arm" "armv6h" "armv7h" "aarch64")
url="http://melonds.kuribo64.net/"
-license=('GPLv3')
-makedepends=('cmake' 'pkg-config')
-depends=('sdl2' 'libslirp' 'qt5-base' 'libepoxy')
-source=("https://github.com/Arisotura/melonDS/archive/$pkgver.tar.gz")
-
-sha256sums=('c50a3855c1f77f58a2b15045687dc399b845224a970fe68ff95919c939ac634f')
+license=("GPL3")
+makedepends=("cmake" "pkg-config")
+depends=("libepoxy" "libslirp" "qt5-base" "sdl2")
+source=("git+https://github.com/Arisotura/melonDS.git#tag=${pkgver}")
+sha256sums=("SKIP")
build() {
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build
+ mkdir -p build
cd build
- cmake ../melonDS-$pkgver \
+
+ cmake ../melonDS \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX='/usr'
+ -DCMAKE_INSTALL_PREFIX="/usr"
make VERBOSE=ON
}
package() {
cd build
+
make DESTDIR="${pkgdir}" install
-} \ No newline at end of file
+}