summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLibrewish2020-10-21 18:32:59 +0530
committerLibrewish2020-10-21 18:32:59 +0530
commit8d5fa86fc293725f17662470403c9eb43fbc134d (patch)
tree203355350567e39e3fceef47a699fc1ecf387179
downloadaur-8d5fa86fc293725f17662470403c9eb43fbc134d.tar.gz
update
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a58168c80506
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = memavaild-git
+ pkgdesc = Improve responsiveness during heavy swapping: keep amount of available memory.
+ pkgver = 0.5.r12.geb346e7
+ pkgrel = 1
+ url = https://github.com/hakavlad/memavaild
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ conflicts = memavaild
+ backup = etc/memavaild.conf
+ source = memavaild-git::git+https://github.com/hakavlad/memavaild.git#branch=master
+ md5sums = SKIP
+
+pkgname = memavaild-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5f9e518d84a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.*
+memavaild-git/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d3f3bcf42ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Librewish <librewish AT gmail.com>
+
+_pkgname=memavaild
+pkgname=${_pkgname}-git
+pkgver=0.5.r12.geb346e7
+pkgrel=1
+pkgdesc="Improve responsiveness during heavy swapping: keep amount of available memory."
+arch=('any')
+url="https://github.com/hakavlad/memavaild"
+license=('MIT')
+source=(
+ "$pkgname::git+https://github.com/hakavlad/memavaild.git#branch=master"
+)
+md5sums=('SKIP')
+depends=(
+ 'python'
+)
+
+makedepends=(
+ 'git'
+)
+conflicts=("${_pkgname}")
+backup=(
+ 'etc/memavaild.conf'
+)
+
+pkgver() {
+ cd "${srcdir}/${pkgname}" || exit 2
+ set -o pipefail
+ git describe --tags --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}" || exit 2
+ make \
+ DESTDIR="${pkgdir}" \
+ PREFIX="/usr" \
+ SBINDIR="/usr/bin" \
+ SYSCONFDIR="/etc" \
+ SYSTEMDUNITDIR="/usr/lib/systemd/system" \
+ install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}