summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatteo2020-05-01 15:20:27 +0200
committerMatteo2020-05-01 15:20:27 +0200
commit859ccd5aa5638b6c18166e8149e6acc23f6a0df1 (patch)
tree7e7c02646d363b018202ddd00150626cc5abcf18
parent7144df0d4df4e6c46a995335fa130c0e1f945ebd (diff)
downloadaur-859ccd5aa5638b6c18166e8149e6acc23f6a0df1.tar.gz
Update to version 3.3.0 using git
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c374c5d66a13..cb8735a4a0da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = memethesis-cli
pkgdesc = Create memes from the terminal
- pkgver = 3.2.1
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/fakefred/memethesis-cli
arch = any
license = GPL3
+ makedepends = git
depends = python>=3
depends = imagemagick
- source = https://github.com/fakefred/memethesis-cli/archive/3.2.1.tar.gz
- sha256sums = 3c0b1727bdc8e7c39885cdbfcdf6bc1daeae84b8be4780c756f053e42a37e31c
+ source = git+https://github.com/fakefred/memethesis-cli.git
+ sha256sums = SKIP
pkgname = memethesis-cli
diff --git a/PKGBUILD b/PKGBUILD
index bd8c77f94fb5..485c59e4f2c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
# Maintainer: Matteo Salonia <saloniamatteo@protonmail.com>
pkgname=memethesis-cli
-pkgver=3.2.1
+pkgver=3.3.0
pkgrel=1
pkgdesc="Create memes from the terminal"
arch=('any')
url="https://github.com/fakefred/memethesis-cli"
license=('GPL3')
depends=('python>=3' 'imagemagick')
-source=("https://github.com/fakefred/memethesis-cli/archive/3.2.1.tar.gz")
-sha256sums=("3c0b1727bdc8e7c39885cdbfcdf6bc1daeae84b8be4780c756f053e42a37e31c")
+makedepends=('git')
+# 3.2.1 is the version that can be downloaded in the releases
+# We will be using 3.3.0 but we'll have to clone the entire repo
+#source=("https://github.com/fakefred/memethesis-cli/archive/3.2.1.tar.gz")
+#sha256sums=("3c0b1727bdc8e7c39885cdbfcdf6bc1daeae84b8be4780c756f053e42a37e31c")
+source=("git+https://github.com/fakefred/${pkgname}.git")
+sha256sums=("SKIP")
package() {
- # go into memethesis-cli-3.2.1-1
- cd "${srcdir}/${pkgname}-${pkgver}"
+ # go into memethesis-cli
+ cd "${srcdir}/${pkgname}"
# install memethesis-cli; binary is in /usr/bin/memethesis
python3 setup.py install --root="$pkgdir"
}