summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorko1N2020-09-06 17:36:03 +0200
committerko1N2020-09-06 17:36:03 +0200
commit473c5db50e04f1fd5370a89f04817098572e7ca2 (patch)
tree3af82a8b23dd74ff8cd35b2f53ecb961b7fc0a83
downloadaur-473c5db50e04f1fd5370a89f04817098572e7ca2.tar.gz
version 0.1.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5cbd65fb5d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = memflow-qemu-procfs-git
+ pkgdesc = Qemu Procfs connector plugin for the memflow physical memory introspection framework
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/memflow/memflow-qemu-procfs
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = rust
+ makedepends = cargo
+ source = git+https://github.com/memflow/memflow-qemu-procfs
+ sha256sums = SKIP
+
+pkgname = memflow-qemu-procfs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..828ac104eddc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer : ko1N <ko1N1337@gmail.com>
+
+pkgver=0.1.1
+pkgname=memflow-qemu-procfs-git
+pkgrel=1
+pkgdesc="Qemu Procfs connector plugin for the memflow physical memory introspection framework"
+arch=(i686 x86_64)
+url="https://github.com/memflow/memflow-qemu-procfs"
+license=(MIT)
+makedepends=(git rust cargo)
+source=("git+https://github.com/memflow/memflow-qemu-procfs")
+sha256sums=("SKIP")
+
+build() {
+ cd "${pkgname%-git}"
+ cargo build --release --all-features
+}
+
+package() {
+ cd "${pkgname%-git}/target/release"
+ install -Dm755 libmemflow_qemu_procfs.so "${pkgdir}/usr/lib/memflow/qemu_procfs.so"
+}