summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAurélien Ooms2020-07-26 22:29:02 +0200
committerAurélien Ooms2020-07-26 22:29:02 +0200
commit0e1fcfb4c113313060c5c989858877c3ebe31e5d (patch)
treeb2210d9b70d7c419c4dd063bf903cc57d4c1afb2
downloadaur-0e1fcfb4c113313060c5c989858877c3ebe31e5d.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41660e4f1bad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = memoize-rust
+ pkgdesc = Cache executable calls
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/aureooms/memoize
+ arch = any
+ license = AGPL-3.0
+ makedepends = git
+ makedepends = rust
+ depends = bash
+ depends = coreutils
+ provides = memoize
+ conflicts = memoize
+ source = https://github.com/aureooms/memoize/archive/v2.0.0.tar.gz
+ md5sums = SKIP
+
+pkgname = memoize-rust
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..998f415a475e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Aurélien Ooms <aurelien.ooms@gmail.com>
+pkgname=memoize-rust
+pkgver=2.0.0
+pkgrel=1
+epoch=
+pkgdesc="Cache executable calls"
+arch=(any)
+url="https://github.com/aureooms/memoize"
+license=('AGPL-3.0')
+groups=()
+depends=('bash' 'coreutils')
+makedepends=('git' 'rust')
+checkdepends=()
+optdepends=()
+provides=('memoize')
+conflicts=('memoize')
+replaces=()
+backup=()
+options=()
+install=
+source=("https://github.com/aureooms/memoize/archive/v${pkgver}.tar.gz")
+noextract=()
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install-rust
+}