summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2022-10-05 22:47:26 -0400
committerLeo P2022-10-05 22:47:26 -0400
commit6f5825e58e301d834b14d4a77264ee1594cde17b (patch)
treecb1d6147ea5d1f82585a19757fb61407accc894f
downloadaur-6f5825e58e301d834b14d4a77264ee1594cde17b.tar.gz
first
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d548fcca33a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = memtest86+-6-git
+ pkgdesc = Memtest86+ is a stand-alone memory tester for x86 and x86-64 architecture computers. It can be loaded and run either directly by a PC BIOS (legacy or UEFI) or via an intermediate bootloader. v6 is NOT READY for production yet!
+ pkgver = v6.00.beta3.r23.gddbee66
+ pkgrel = 2
+ url = https://github.com/memtest86plus/memtest86plus
+ arch = x86_64
+ license = GPL2
+ source = git+https://github.com/memtest86plus/memtest86plus.git
+ sha256sums = SKIP
+
+pkgname = memtest86+-6-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..eb4daf4c208a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.*
+memtest86*/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..114b63819e19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=memtest86+-6-git
+pkgver=v6.00.beta3.r23.gddbee66
+pkgrel=2
+pkgdesc='Memtest86+ is a stand-alone memory tester for x86 and x86-64 architecture computers. It can be loaded and run either directly by a PC BIOS (legacy or UEFI) or via an intermediate bootloader. v6 is NOT READY for production yet!'
+arch=('x86_64')
+url=https://github.com/memtest86plus/memtest86plus
+license=('GPL2')
+source=('git+https://github.com/memtest86plus/memtest86plus.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "memtest86plus"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "memtest86plus"/build64
+ make
+ make iso
+}
+
+package() {
+ cd "memtest86plus"/build64
+ install -Dm644 memtest.bin "$pkgdir"/boot/memtest86plus-6/memtest.bin
+ install -Dm644 memtest.efi "$pkgdir"/boot/memtest86plus-6/memtest.efi
+ install -Dm644 memtest.iso "$pkgdir"/usr/share/memtest86plus-6/memtest.iso
+}