summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-30 09:24:36 +0200
committerChristian Hesse2015-06-30 09:24:36 +0200
commit2c66c1d069db7a809ab1243772eb232a23475295 (patch)
tree21edfca3ef2f5abf716dfc3c319c52a1624f22c9
downloadaur-2c66c1d069db7a809ab1243772eb232a23475295.tar.gz
initial import of memtest86+-pxe-git 0.r22.g96cc317-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65aac27b72fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = memtest86+-pxe-git
+ pkgdesc = An advanced memory diagnostic tool as a PXE NBP - git checkout
+ pkgver = 0.r22.g96cc317
+ pkgrel = 1
+ url = http://www.ipxe.org/
+ arch = any
+ license = GPL
+ makedepends = git
+ provides = memtest86+-pxe
+ conflicts = memtest86+-pxe
+ source = memtest86-pxe::git://git.ipxe.org/people/mcb30/memtest.git#branch=pxe501
+ sha256sums = SKIP
+
+pkgname = memtest86+-pxe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b37c2a4fe45e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+
+pkgname=memtest86+-pxe-git
+pkgver=0.r22.g96cc317
+pkgrel=1
+pkgdesc='An advanced memory diagnostic tool as a PXE NBP - git checkout'
+arch=('any')
+url='http://www.ipxe.org/'
+license=('GPL')
+makedepends=('git')
+provides=('memtest86+-pxe')
+conflicts=('memtest86+-pxe')
+source=('memtest86-pxe::git://git.ipxe.org/people/mcb30/memtest.git#branch=pxe501')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd memtest86-pxe/
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ echo "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG}).r$(git rev-list --count ${GITTAG}..).g$(git log -1 --format="%h")"
+ else
+ echo "0.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+ fi
+}
+
+build() {
+ cd memtest86-pxe/
+
+ make CC='gcc -fno-pie' memtest.0
+}
+
+package() {
+ cd memtest86-pxe/
+
+ install -D -m0755 memtest.0 ${pkgdir}/usr/lib/memtest86+-pxe/memtest.0
+}
+