summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEarnestly2019-02-24 11:22:42 +0000
committerEarnestly2019-02-24 11:22:42 +0000
commit31f7ac6fb37a2fa1ea10f1fec4eb6d8eeb63cd05 (patch)
treec9a73c866c1ad992b9fb024095dbd9bf4d6a8bb9
downloadaur-31f7ac6fb37a2fa1ea10f1fec4eb6d8eeb63cd05.tar.gz
add memutils
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acb141f1f9f0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = memutils-git
+ pkgdesc = utilities for watching and modifying the memory of running processes
+ pkgver = r49.g8447865
+ pkgrel = 1
+ url = https://git.cloudef.pw/memutils.git
+ arch = x86_64
+ license = zlib
+ makedepends = git
+ depends = glibc
+ provides = memutils
+ conflicts = memutils
+ source = git+https://git.cloudef.pw/memutils.git
+ sha256sums = SKIP
+
+pkgname = memutils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75d15600cf16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+pkgname=memutils-git
+pkgver=r49.g8447865
+pkgrel=1
+
+pkgdesc='utilities for watching and modifying the memory of running processes'
+url='https://git.cloudef.pw/memutils.git'
+arch=('x86_64')
+license=('zlib')
+
+depends=('glibc')
+makedepends=('git')
+
+provides=('memutils')
+conflicts=('memutils')
+
+source=('git+https://git.cloudef.pw/memutils.git')
+
+sha256sums=('SKIP')
+
+pkgver() {
+ cd memutils
+ printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd memutils
+ make
+}
+
+package() {
+ cd memutils
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ # install -Dm0644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}