summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwicast2015-08-12 18:24:32 +0800
committerwicast2015-08-12 18:35:38 +0800
commit51e0f9a29591d91291f5b104de5cb2f3824aef7a (patch)
tree798f4d40e269dc706fde9e073e9fb4db960c8341
downloadaur-51e0f9a29591d91291f5b104de5cb2f3824aef7a.tar.gz
Init
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD45
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77750a3b4b4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = menda-icon-themes-git
+ pkgver = 20141219
+ pkgrel = 1
+ url = https://github.com/manjaro/menda-icon-themes
+ arch = any
+ license = GPL
+ depends = hicolor-icon-theme
+ depends = librsvg
+ optdepends = menda-themes: Recommended themes
+ optdepends = menda-themes-dark: Recommended themes
+ replaces = menda-icon-themes
+ options = !emptydirs
+ options = !strip
+ source = menda-icon-themes-git::git+https://github.com/manjaro/menda-icon-themes.git
+ sha1sums = SKIP
+
+pkgname = menda-circle-icon-theme-git
+ pkgdesc = Menda Circle Icon Theme
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1d65adf6de3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ac164f4bbb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: anexation
+# Contributor: Rob McCathie <rob@manjaro.org>
+
+pkgbase=menda-icon-themes-git
+#pkgname=('menda-circle-icon-theme' 'menda-square-icon-theme')
+pkgname=('menda-circle-icon-theme-git')
+pkgver=r1.a2eb4a0
+pkgrel=1
+arch=('any')
+url="https://github.com/manjaro/menda-icon-themes"
+license=('GPL')
+depends=('hicolor-icon-theme' 'librsvg')
+optdepends=('menda-themes: Recommended themes'
+ 'menda-themes-dark: Recommended themes')
+options=(!emptydirs !strip)
+replaces=('menda-icon-themes')
+#source=("${pkgbase}-${pkgver}-${pkgrel}.zip::${url}/archive/master.zip")
+source=("${pkgbase}::git+https://github.com/manjaro/menda-icon-themes.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$pkgbase"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package_menda-circle-icon-theme-git() {
+ pkgdesc="Menda Circle Icon Theme"
+
+ install -dm755 "${pkgdir}/usr/share/icons"
+ #install -Dm755 "${srcdir}/${pkgbase}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cp -r "${srcdir}/${pkgbase}/Menda-Circle" "${pkgdir}/usr/share/icons"
+ find "${pkgdir}/usr/share/icons" -type d -exec chmod 755 '{}' \;
+ find "${pkgdir}/usr/share/icons" -type f -exec chmod 644 '{}' \;
+}
+
+#package_menda-square-icon-theme() {
+# pkgdesc="Menda Square Icon Theme"
+#
+# install -dm755 "${pkgdir}/usr/share/icons"
+# #install -Dm755 "${srcdir}/${pkgbase}-${_git}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+# cp -r "${srcdir}/${pkgbase}-${_git}/Menda-Square" "${pkgdir}/usr/share/icons"
+# find "${pkgdir}/usr/share/icons" -type d -exec chmod 755 '{}' \;
+# find "${pkgdir}/usr/share/icons" -type f -exec chmod 644 '{}' \;
+#}