summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKNOB2020-11-23 22:12:15 -0500
committerKNOB2020-11-23 22:12:15 -0500
commitb19855f098eab465f62e5f38bef4d465b11ee620 (patch)
tree5f7667b08399aaefa49a9c4523dae6a6722b19dd
downloadaur-b19855f098eab465f62e5f38bef4d465b11ee620.tar.gz
Added PKGBUILD and SRCINFO as required by the AUR submission guidelines; Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd72c0bd27cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = menu-bookmark-git
+ pkgdesc = A website bookmark manager using the menu backend (git version).
+ pkgver = r17.f2b5387
+ pkgrel = 1
+ url = https://gitlab.com/KNIX3/bookmarkmenu
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = menu
+ depends = dmenu
+ provides = menu-bookmark
+ source = menu-bookmark-git::git+https://gitlab.com/KNIX3/bookmarkmenu.git
+ md5sums = SKIP
+
+pkgname = menu-bookmark-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4840d7c10ac9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: John Smith <knobpersonal@gmail.com>
+pkgname='menu-bookmark-git'
+pkgver=r17.f2b5387
+pkgrel=1
+pkgdesc="A website bookmark manager using the menu backend (git version)."
+arch=('any')
+url="https://gitlab.com/KNIX3/bookmarkmenu"
+license=('GPL')
+depends=('menu' 'dmenu')
+makedepends=('git')
+provides=('menu-bookmark')
+source=("$pkgname::git+https://gitlab.com/KNIX3/bookmarkmenu.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 ./bookmarkmenu "$pkgdir/usr/bin/bookmarkmenu"
+ install -Dm644 ./README.md "$pkgdir/usr/share/doc/$pkgname"
+}