summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Millar2017-03-02 19:56:07 -0700
committerJesse Millar2017-03-02 19:56:07 -0700
commitc4d7ce430dd259cd33fd1b2d25a539b1750a1d85 (patch)
tree08dcb6716fd310292deb8fc0045b8d04b23ca7ef
downloadaur-c4d7ce430dd259cd33fd1b2d25a539b1750a1d85.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD33
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a85d4f0cd151
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = menu-calc-git
+ pkgdesc = A calculator for Rofi/dmenu(2)
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/jessemillar/menu-calc
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = bc
+ depends = xclip
+ optdepends = rofi: calculator search support,
+ optdepends = dmenu: calculator search support,
+ optdepends = dmenu2: calculator search support
+ provides = =
+ source = git+https://github.com/jessemillar/menu-calc
+ md5sums = SKIP
+
+pkgname = menu-calc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..468d11399f91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jesse Millar <hellojessemillar [at] gmail [dot] com>
+# Contributor: onespaceman
+
+pkgname=menu-calc-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A calculator for Rofi/dmenu(2)"
+arch=('i686' 'x86_64')
+url="https://github.com/jessemillar/menu-calc"
+license=('MIT')
+depends=(bc xclip)
+optdepends=('rofi: calculator search support', 'dmenu: calculator search support', 'dmenu2: calculator search support')
+makedepends=('git')
+provides=('=')
+source=("git+https://github.com/jessemillar/menu-calc")
+_gitname="menu-calc"
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git describe --tags | sed "s/.//"
+}
+
+prepare() {
+ cd "$srcdir/$_gitname"
+ git submodule update --init
+}
+
+package() {
+ cd "$_gitname"
+
+ sudo cp "=" /usr/bin
+}