summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarbUk2020-12-21 15:15:20 +0100
committerBarbUk2020-12-21 15:15:20 +0100
commit2237b5d972326e1e3d4edbca1db4d5da81e1866c (patch)
treea1abf3c33808cb5f82a5a7dee31a1b4772ce7ad1
downloadaur-2237b5d972326e1e3d4edbca1db4d5da81e1866c.tar.gz
First release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..420fad5cf93f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = menu-qalc
+ pkgdesc = A calculator for Rofi/dmenu(2)
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = https://github.com/barbuk/menu-qalc
+ arch = any
+ license = MIT
+ depends = libqalculate
+ depends = xclip
+ optdepends = dmenu: required if rofi is not installed
+ optdepends = rofi: required if dmenu is not installed
+ conflicts = menu-calc
+ source = https://github.com/barbuk/menu-qalc/archive/v1.4.1.tar.gz
+ sha256sums = 2388a6fe41a08662ccd4c4dba118126ab89ca35fd38fc4dbc445e94f727d7fb3
+
+pkgname = menu-qalc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a30827f475dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Julien Virey <julien.virey@gmail.com>
+pkgname=menu-qalc
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="A calculator for Rofi/dmenu(2)"
+arch=('any')
+url="https://github.com/barbuk/menu-qalc"
+license=('MIT')
+depends=('libqalculate' 'xclip')
+conflicts=('menu-calc')
+optdepends=('dmenu: required if rofi is not installed'
+ 'rofi: required if dmenu is not installed')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('2388a6fe41a08662ccd4c4dba118126ab89ca35fd38fc4dbc445e94f727d7fb3')
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/bin"
+ install -D -m755 ./= "$pkgdir/usr/bin/="
+ mkdir -p "$pkgdir/usr/share/man/man1"
+ install -D -m644 ./=.1 "$pkgdir/usr/share/man/man1/=.1"
+ install -D -m644 ./menu-calc.1 "$pkgdir/usr/share/man/man1/menu-calc.1"
+}